Deepin20 desktop issue with window effect

Hello,

I don’t know if anybody available in this sub-forum to reply, but I am facing an issue with latest deepin20 desktop in Manjaro 20.1.1.

I prepared a barebone CLI Manjaro system using Architect and installed latest deepin DE over it via pacman, deepin-extra package group is also installed.
But sometimes when I login into desktop, I found that “Window Effect” is disabled in Control Center --> Personalization for no reason and I can’t re-toggle it. It simply stay stuck.

After several reboot, window effect works again.

is this a bug? Any solution to this?

My system has AMD Radeon Vega 8 integrated GPU and free driver (video-linux, amdgpu) installed.

Deepin-kwin is installed?

Yes, installed and just re-installed via pacman.

Is deepin-wm also installed?

If so can you remove that one (just with -R and not -Rns)

 sudo pacman -R deepin-wm

also remove

 ~/.config/kwinrc 

If you have that file

reboot and see if it helps

After toggling four or five times I received a message saying kwin was unstable. I tried to install deepin-wm and switched to that one, the effects were on. By the way I think deepin-wm is abandoned so it’s not the best solution.

deepin-wm is deprecated indeed in favor of deepin-kwin (not kwin itself).

So if it got installed somehow it breaks the effects and the only way to resolve it is remove is and also remove kwinrc (most of the time)

It was actually deepin-kwin that was causing problems due to it being unstable (whatever this means).
Deepin-wm was not installed natively, however it’s in the repos so I installed it and switched to it and then window effects worked almost as expected

1 Like

Okay noted.

I dont use Deepin (anymore) so I only had my own reference from way back.
Still not the best solution as you say since deepin-wm is deprecated. Then again if the effects dont work…

could be the failsafe mode in kwin

I that case you could try set OpenGLIsUnsafe=false if it is true in ~/.config/kwinrc

[Compositing]
OpenGLIsUnsafe=false

On a crash it will be back at true, so it is a workarround like installing deepin-wm

1 Like

In fact I do not use deepin anymore too :laughing:
At least for now, but I see there are progress lately so I’ll keep a look while I use GNOME

Trying…
I found the system don’t have deepin-wm installed. So didn’t remove that kwinrc file. Just edited it as you said.

Update:

After editing the file and a reboot, Window effect working again. Let’s see if the issue really resolved or not.

installing deepin-wm and removing deepin-kwin does the work for now but still it’s a temporary solution. I think the problem is being caused by some dependency of deepin-kwin because in my system deepin-kwin was not updated. It was working before the update and window effects are not working after update.

After following what @SLaItEr suggested above and editing ~/.config/kwinrc file, problem still not solved (window effect is gone after reboot) and this is my current content of the file:

[Compositing]
Enabled=true
OpenGLIsUnsafe=false
OpenGLIsUnsafeCount=6

So should I stick with deepin-wm as temporary solution?

yes both are workarounds

the one I provides on;y works till a next ’ crash’ so sitck with deepin-wm for the time being.

Ok, switched to deepin-wm.
Also keeping an eye on deepin-kwin if they bring any update.

I’m on Archdeepin and compositing has been messed up for quite a few weeks now. However, I’m now wondering whether it’s a conflict with the pamac(-aur) notification/indicator icon.

As a test, I deleted $HOME/.config/kwinrc and rebooted.

When you first log back into deepin desktop, the compositing and transparency is working. You can see the blur effect in the panel and start menu. Then pamac finishes its checks for updates, and the indicator icon as well as notification message pops up. At this point, the screen flickers/jumps, and compositing (desktop effect) crashes or is removed.

I was able to repeat this in both my VM and real metal install.

I’m on deepin-kwin and have removed deepin-wm.

[Update] Nope. I removed pamac-aur from my VM and rebooted. After I logged back in, it certainly seemed ok at first, with transparency in panel and start menu. Until I clicked on the start menu button. Then the screen flickered again and compositing was wiped out.

Downgrading the KDE dependecies worked for me. Though it’s only a temporary solution you can try this if you want deepin-kwin to work:

sudo pacman -S downgrade

downgrade "kactivities=5.74.0-1" "karchive=5.74.0-1" "kauth=5.74.0-1" "kbookmarks=5.74.0-1" "kcmutils=5.74.0-1" "kcodecs=5.74.0-1" "kcompletion=5.74.0-1" "kconfig=5.74.0-1" "kconfigwidgets=5.74.0-1" "kcoreaddons=5.74.0-1" "kcrash=5.74.0-1" "kdbusaddons=5.74.0-1" "kdeclarative=5.74.0-1" "kded=5.74.0-1" "kglobalaccel=5.74.0-1" "kguiaddons=5.74.0-1" "ki18n=5.74.0-1" "kiconthemes=5.74.0-1" "kidletime=5.74.0-1" "kio=5.74.0-1" "kirigami2=5.74.0-1" "kitemmodels=5.74.0-1" "kitemviews=5.74.0-1" "kjobwidgets=5.74.0-1" "knewstuff=5.74.0-1" "knotifications=5.74.0-1" "kpackage=5.74.0-1" "kservice=5.74.0-1" "ktextwidgets=5.74.0-1" "kwallet=5.74.0-1" "kwayland=5.74.0-1" "kwidgetsaddons=5.74.0-1" "kwindowsystem=5.74.0-1" "kxmlgui=5.74.0-1" "frameworkintegration=5.74.0-1" "networkmanager-qt=5.74.0-1" "plasma-framework=5.74.0-1" "kdecoration=5.19.5-1" "kscreenlocker=5.19.5-1" "kwayland-server=5.19.5-1" "kwin=5.19.5-2"

Then reboot

PS: Don’t use it if you also have KDE installed alongside.

The issue is tracked here: [Arch] Window effects broken since last update · Issue #1945 · linuxdeepin/developer-center · GitHub

Thanks, but that’s Deepin for you. IMO, no point downgrading since it’ll probably come back again eventually even if it’s fixed this time round. I’m just tracking the ups and downs of deepin on my test install for curiosity’s sake. IIRC, this is the 3rd or 4th time the compositing issue has resurfaced after being “fixed”.

The problem is the support of dde-kwin (deepin kwin plugin) with kwin. So basically whenever there is a big release of kwin, the dde-kwin plugin needs to be made compatible. I hope this compatibility gets fixed soon because the Deepin DE is very good imo.