Deepin screen recorder missing it's icons in XFCE

Link to image of the problem: lh4.googleusercontent .com/zWdGk2h5RBQDSXCOFhAVVPHhhqeUjwBxesqJOJhHBYf-28WgQn9WV3xhJvblmV6c1hU9tUAqNNiNM0MD4W_f=w2560-h1237-rw


Before Manjaro was updated introducing deepin 20 beta applications everything was great.
But ever since those apps went to ver 20, I had 2 problems:

1. Apps would not have a dark theme.
So I fixed it by adding below to ~/.profile:

2. But regardless of 1., deepin-screen-recorder won’t show it’s icons properly.
At post beginning I’ve linked an image at which I show the problem - I’m a new user so I couldn’t paste link so you need to stitch it together.
The selected area are buttons that normally have icons showing rectancle, elipse, arrow/line, text etc.
As I hover on the “arrow” option, it shows the label - icon is still missing.

What I’ve tried so far to get the icons back:

  • I’ve tried changing the icon packs in Appearance senttings of Manjaro XFCE.
    This brought back the first and last icon - rectangle and text. All rest were still missing.
    I’ve installed all icon packs available in Official repo - none fixed it.
  • Then I’ve tried Kvantum Manager:
    QT_QPA_PLATFORMTHEME=kvantum in ~/.profile and relogin
    All changes did apply to deepin (QT5 based app), but icons were still missing.

What’s interesting, if I run deepin-system-recorder as root, the app has all the icons - only dark theme, but icons are there.

So what should I do to get those icons back?

More info:
I’m on Manjaro 20.1, all most recent updates (05 Sep)
QT5 and deepin info:

  • deepin-screen-recorder

These settings apply to GTK-based applications only.

The Xfce edition has an application called qt5ct (QT5 Configuration Tool) pre-installed. You can use this tool to configure the settings for QT-based applications.

Open the tool by running qt5ct in a terminal window or by searching in the Whisker Menu.

Once opened, you’ll see a tab called Icon Theme. There you can change the icon theme used for QT-based applications.
Try changing the icon theme there and see if that helps with deepin-screen-recorder.

Bare in mind that the icon theme you set there will affect all QT-based applications.

1 Like

No, that’s why I’ve set
in ~/.profile.
That made icons from Appearance apply to QT apps. But with little success.

I forgot to mention qt5ct in OP.
After switching to qt5ct correctly and setting icon theme, icons theme changes were analogical as to trials without qt5ct - they were applied, but at best, only 2 icons appeared in the app.

So I just dropped qt5ct entirely.

Like I said, the interesting thing is that all icons show when running the app as root…