Deep sleep not available

I have recently installed Manjaro on a brand new laptop and everything works without a hitch, except for sleep. It would seem it is one of these laptops with the fancy new deep sleep mode, but the laptop only goes into s2idle mode regardless of what I do, which basically leaves the entire laptop on, but kills my keyboard and touchpad.

What I have tried so far:

  • Echoing “deep” and “shallow” into /sys/power/mem_sleep - It replies “Invalid Argument” (s2idle works)
  • Echoing “standby” into /sys/power/state - It replies “Invalid argument” (freeze works)
  • Moving to 5.7 kernel and 5.9 kernel
  • Trying to find an EFI setting to force S3 sleep
  • Googling a whole bunch, without any real results

I am thinking the problem here is that the kernel doesn’t really support shallow and deep modes and I am not enough of a kernel nerd to be able to find out what flags I need to set or what module I have to install to enable this, is anyone able to help with this?

Check if deep sleep is active in the BIOS setup. My laptop has that setting.

As for S3, try systemctl suspend

Hey man, my bios sadly does not have a deep sleep setting, as it would seem to be the default setting of the laptop. :confused:

systemctl suspend

Just does the same as pressing the sleep button, computer still running, but touchpad and screen gets turned off.

This is not normal. Try kernel 5.4. If it doesn’t work. After resuming from standby post the output of journalctl -p3 -b

5.4 seems to just “freeze” the entire startup process somehow. If I jump to screen 2 I can log in, but screen 1 is just a frozen cursor. No devices really seem to work, even though I am able to log in, I am assuming because the hardware is from 2020Q4, so probably not at all supported in 5.4.

Sorry for the screenshot, but half the keyboard and the mouse don’t work. :stuck_out_tongue:

Ok then, you need a newer kernel. Probably, you need to wait a bit until things get better. Boot with a newer kernel and post the same output.

I tried 5.10rc5 and i get the exact same error messages. Except “failed to get backlight” and “snd_soc_register” lines were there twice instead of once. So I am thinking it might be a while before sleep gets supported. This is the only issue I have though, so I think I can live with it for a while. :stuck_out_tongue:

If it helps at all, the device is a Lenovo Yoga/Thinkpad 7 with the 4500U AMD APU.

I found this. It may help.

Thanks man. It’s a bit annoying that Lenovo doesn’t just include it in the EFI. :stuck_out_tongue: