Decrypt disk on boot - keymap change not possible


I did a fresh installation yesterday. On the disk partitioning part, I chose disk encryption and set a password. Now the password must be entered on boot. After typing the password, it tells I typed a wrong one. After some time, I noticed, that its an english keyboard layout instead of german. So it switched “y” with “z”. After typing it in english, it worked.

Now I googled and tried to change the layout. There is a nice documentation here: ARCHWIKI => index.php/Talk:GRUB#Custom_keyboard_layout

I created the keyboard file with the command and moved it into the /boot/grub folder. After modifying /etc/default/grub and /etc/grub.d/40_custom and updating with “update-grub” and “grub-mkconfig -o /boot/grub/grub.cfg”, it seems there was no change.

I did this in this way, but had no luck. Maybe you have an idea, what I could try?

Thanks very much

There is no way in changing the keymap this early in the boot process.

If you need to switch the keymap, you night want to ditch grub and switch to an unencrypted boot and unlock with systemd later in the boot process. At this time, you can choose the keymap.

Hi xabuu,

thanks very much for your answer.

Is it possible to do this with systemd-boot? Or is the separate boot partition the only way to get another keymap?


It should work with systemd-boot. Because the Kernel Image will be stored on the unencrypted $EFI partition.
Of course the $EFI partition is not the boot partition but with systemd-boot it is quite similar.

Add with cryptsetup luksAddKey another key and type your password like you using a english keymap.

@xabbu Thanks very much, I am going to try it with systemd-boot.

@Hagen Sure this can be an option. I thought to an usb stick with an cryptfile, too. But a workaround should not be a solution for something, that should work. Like xabbu wrote, I have to change my setup and it is possible. So this is the right way for me. Thanks :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.