Dead keys doesn't work everywhere


I started using Manjaro last year, and I don’t remember since when I have this problem, but my dead keys don’t work everywhere. For example, typing ^ then e should become ê. It works in Firefox, VSCodium and some others, but doesn’t work in many other apps such as Yakuake, Konsole, Ghostwriter… My keyboard is French Azerty, with dead keys, and none of the “French variants” in Manjaro Settings solve the issue…

The command localectl returns:

System Locale: LANG=fr_FR.UTF-8
VC Keymap: fr
X11 Layout: fr
X11 Variant: oss_nodeadkeys

And I can’t figure out why the X11 Variant is set to “nodeadkeys”…

Does anyone have an idea to help me fix this?


Yeah, you open google and search:


I read the entire topic you’ve suggested, tried what was advised, and I just figured out that it wasn’t exactly the same problem :upside_down_face:
Indeed, my dead keys work fine in tty, but not in Konsole, nor Yakuake, nor Ghostwriter, nor many other software programs.

Might you have other topics I didn’t find on Google, because yes, I searched before coming here :slightly_smiling_face:

I’m also using French layout (both built-in and external keyboards are azerty), plus Arabic and Tifinagh layouts.

All letters with accent work fine everywhere inside Qt and GTK apps.

I simply let the default Keyboard model: Generic | Generic 104-key PC

and in terminal it shows:

System Locale: LANG=en_US.UTF-8
    VC Keymap: fr
   X11 Layout: fr
    X11 Model: pc105

Thanks for your answer, I don’t understand why this don’t work for me…
I tried many different things with localectl, restarting X server, I still don’t have working dead keys on Qt apps (it seems that all GTK apps work fine, but Qt apps don’t work)

By the way, sorry if my English is bad :sweat_smile:

I don’t really know why but using the same layouts as usual, now key mapping is weird!
I can’t do hashtag, now it’s a ³, and same for all symbols in numbers line (with Alt Gr)
I reseted all keyboards settings to default, but the problem is still there…
How can I effectively change the layout to default french layout?

Try select French > Default as system-wide layout in Manjaro Settings

Then select French layout as first in the list in KDE Plasma settings

1 Like

I tried what you suggested…
At least I now have most keys working correctly, but I still not have dead keys…

I tried each French layout and the problem is still there…
I can use dead keys in some softwares (Firefox, VSCode) but not in some others: Yakuake, Konsole, Ghostwriter, TexMaker…

I have the latest version of everything in my computer, and I switched to Plasma 6, and the problem is still there…
I now have this with localectl:

System Locale: LANG=fr_FR.UTF-8
    VC Keymap: fr
   X11 Layout: fr
    X11 Model: pc105
  X11 Variant: latin9_nodeadkeys

However, I didn’t choose a layout with “no dead keys” specified…