Dead grub on system with Win10 and dead Ubuntu [currently unbootable]

So I currently have a mildly annoying problem. I have a partially installed GRUB from repeated failed installed Ubuntu/Manjaro attempts to attempt to repair my Ubuntu which was dualbooted with win10 (I have around 10 partitions on my drive currently from failed attempts).

However, I forgot to disable fast boot in Windows 10 before trying to reinstall Ubuntu. I thought the ubuntu installer was the issue (it is known to be buggy) but it turns out that nope, its totally my fault. I cannot boot into windows 10 currently (unless there is a back way) because the dualboot which includes windows is dead (partially installed GRUB is no good), which is annoying since to turn off fast boot in windows 10, being able to boot into win10 seems to me like a requirement. I can only boot onto live Manjaro/Ubuntu or whatever ISO files at the present moment and due to the fast boot being enabled on windows 10 (at least i think it is, if it isnt then I do not know what the problem is) I cannot install said ISO files to my hard disk.

I have done dualboot installs before but on this occasion I made a really stupid mistake. Sorry for any inconvenience to anyone on the forum, I just really need to be able to restore my PC right now. Wiping the drive is not really an option but if it is absolutely necessary I suppose I will have to do it.

My main questions are: Am I screwed? Is there a way to save this? and if so, how?

Hello @Rubiksmath :wink:

  1. Fastboot on Windows only matters when you shrink or mount its partition. Or do you mean fastboot at your UEFI Settings?

  2. Explain “partially installed grub”?!

  3. Maybe start with some basic information, so one can follow you:

inxi -Fv7azy
sudo parted -l

Hi, sorry for lack of information earlier. I will try my best to briefly explain:
1.Fastboot and secure boot are disabled in my UEFI settings currently however I believe it is enabled in Win10
2.What I mean by partially installed grub is that I had a working grub loader on /dev/sda which controlled the dualboot between my windows 10 and Ubuntu. I then decided to overwrite my Ubuntu install with a clean copy of Ubuntu using the installer, which exited with an error “unable to install grub on /dev/sda, this error is fatal” (or similar i cannot remember exact). At this stage I now have a corrupted grub on /dev/sda where if I attempt to boot anything (either windows or Ubuntu) it immediately enters a grub error screen and starts rescue mode.
3. I will get to this in around 8 hours time it is currently extremely late, I promise I will get this info to you though.

From the Manjaro Live USB running the first command (edit: this time with root permissions) gives

  Kernel: 6.1.25-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=manjaro misolabel=MANJARO_KDE_2210 quiet systemd.show_status=1
    splash driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=1
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.8 wm: kwin_x11 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: X570M Pro4 serial: <filter>
    UEFI: American Megatrends v: P3.40 date: 01/27/2021
  Message: No system battery data found. Is one present?
  RAM: total: 15.54 GiB used: 3.77 GiB (24.3%)
  Array-1: capacity: 128 GiB slots: 4 EC: None max-module-size: 32 GiB
    note: est.
  Device-1: DIMM 0 type: no module installed
  Device-2: DIMM 1 type: DDR4 detail: synchronous unbuffered (unregistered)
    size: 8 GiB speed: 3600 MT/s volts: curr: 1.2 min: 1.2 max: 1.2 width (bits):
    data: 64 total: 64 manufacturer: Corsair part-no: CMW16GX4M2C3600C18
    serial: N/A
  Device-3: DIMM 0 type: no module installed
  Device-4: DIMM 1 type: DDR4 detail: synchronous unbuffered (unregistered)
    size: 8 GiB speed: 3600 MT/s volts: curr: 1.2 min: 1.2 max: 1.2 width (bits):
    data: 64 total: 64 manufacturer: Corsair part-no: CMW16GX4M2C3600C18
    serial: N/A
  Info: model: AMD Ryzen 5 5600X socket: AM4 bits: 64 type: MT MCP arch: Zen 3+
    gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
    family: 0x19 (25) model-id: 0x21 (33) stepping: 0 microcode: 0xA201009
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB L3: 32 MiB
    desc: 1x32 MiB
  Speed (MHz): avg: 2325 high: 3700 min/max: 2200/4650 boost: enabled
    base/boost: 3700/4650 scaling: driver: acpi-cpufreq governor: schedutil
    volts: 1.1 V ext-clock: 100 MHz cores: 1: 2200 2: 2200 3: 2200 4: 3700
    5: 2200 6: 2200 7: 2200 8: 2200 9: 2200 10: 2200 11: 2200 12: 2200
    bogomips: 88675
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists erms extapic
    extd_apicid f16c flushbyasid fma fpu fsgsbase fsrm fxsr fxsr_opt ht
    hw_pstate ibpb ibrs ibs invpcid irperf lahf_lm lbrv lm mba mca mce
    misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt
    nrip_save nx ospke osvw overflow_recov pae pat pausefilter pclmulqdq
    pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pku pni popcnt
    pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni
    skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor
    svm svm_lock syscall tce topoext tsc tsc_scale umip v_spec_ctrl
    v_vmsave_vmload vaes vgif vmcb_clean vme vmmcall vpclmulqdq wbnoinvd wdt
    xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA106 [GeForce RTX 3060] vendor: Micro-Star MSI
    driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-03) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 07:00.0 chip-ID: 10de:2503 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 81 s-size: 602x343mm (23.70x13.50")
    s-diag: 693mm (27.28")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 82
    size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce RTX
    3060/PCIe/SSE2 direct-render: Yes
  Device-1: NVIDIA GA106 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 07:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 09:00.4 chip-ID: 1022:1487 class-ID: 0403
  API: ALSA v: k6.1.25-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.70 status: n/a (root, process) with: wireplumber
    status: active tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active (root, process)
    tools: pacat,pactl
  Device-1: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 03:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: global
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 960.17 GiB used: 0 KiB (0.0%)
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 QVO 1TB
    family: based SSDs size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B sata: 3.3 speed: 6.0 Gb/s type: SSD serial: <filter>
    rev: 1B6Q temp: 25 C scheme: MBR
  SMART: yes state: enabled health: PASSED on: 272d 19h cycles: 593
    written: 48.54 TiB
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: USB 3.2Gen1
    size: 28.65 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
  Message: No partition data found.
  Alert: No swap data was found.
  ID-1: /dev/sda1 maj-min: 8:1 size: 50 MiB fs: ntfs label: System Reserved
    uuid: 0270E6B470E6AD9B
  ID-2: /dev/sda2 maj-min: 8:2 size: 636.04 GiB fs: ntfs label: N/A
    uuid: 34FEE81DFEE7D560
  ID-3: /dev/sda3 maj-min: 8:3 size: 507 MiB fs: ntfs label: N/A
    uuid: 78A4574AA45709D0
  ID-4: /dev/sda4 maj-min: 8:4 size: 1 KiB fs: N/A label: N/A uuid: N/A
  ID-5: /dev/sda5 maj-min: 8:5 size: 953 MiB fs: vfat label: N/A
    uuid: E720-3712
  ID-6: /dev/sda6 maj-min: 8:6 size: 96.73 GiB fs: ext4 label: N/A
    uuid: 64cfb77a-efcc-4b74-9f6a-2b2f9523cf7b
  ID-7: /dev/sda7 maj-min: 8:7 size: 52.17 GiB fs: ext4 label: N/A
    uuid: 0e2862ca-b081-4772-8318-897c6a846d6e
  ID-8: /dev/sda8 maj-min: 8:8 size: 92.93 GiB fs: ext4 label: N/A
    uuid: f6062564-de3d-4538-a160-6d88de746fdf
  ID-9: /dev/sdb1 maj-min: 8:17 size: 3.88 GiB fs: iso9660
  ID-10: /dev/sdb2 maj-min: 8:18 size: 4 MiB fs: vfat label: MISO_EFI
    uuid: B25B-A794
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: Corsair K95 RGB Platinum Keyboard [RGP0056]
    type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0
    speed: 12 Mb/s power: 500mA chip-ID: 1b1c:1b2d class-ID: 0300
    serial: <filter>
  Device-2: 3-2:3 info: Corsair DARK CORE RGB PRO SE Gaming Mouse
    type: Mouse,HID,Keyboard driver: hid-generic,usbhid interfaces: 4 rev: 2.0
    speed: 12 Mb/s power: 500mA chip-ID: 1b1c:1b7e class-ID: 0301
    serial: <filter>
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 4-3:2 info: SanDisk Ultra type: Mass Storage driver: usb-storage
    interfaces: 1 rev: 3.2 speed: 5 Gb/s power: 896mA chip-ID: 0781:5581
    class-ID: 0806 serial: <filter>
  Hub-5: 5-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 6-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 54.6 C mobo: N/A gpu: nvidia temp: 39 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 243 Uptime: 9m wakeups: 0 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1204 libs: 328 tools: pamac pm: flatpak pkgs: 0 Shell: Zsh (sudo)
  v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.26

and running the second gives

Model: ATA Samsung SSD 870 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type      File system  Flags
 1      1049kB  53.5MB  52.4MB  primary   ntfs
 2      53.5MB  683GB   683GB   primary   ntfs
 4      683GB   1000GB  317GB   extended
 7      683GB   739GB   56.0GB  logical   ext4
 8      795GB   895GB   99.8GB  logical   ext4
 6      895GB   999GB   104GB   logical   ext4
 5      999GB   1000GB  999MB   logical   fat32        boot, esp
 3      1000GB  1000GB  532MB   primary   ntfs         msftres

Model:  USB  SanDisk 3.2Gen1 (scsi)
Disk /dev/sdb: 30.8GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      4170MB  4174MB  4194kB  primary               esp

Hope this helps you understand a bit more, sorry bout not doing this earlier.

After a quick look, you still seem to have the esp partition,
list the output from the efibootmgr (while in the Live USB),
that’s just a ‘read/list’ op, no harm, while sudo efibootmgr -o is to change the order, or see if you can change the boot order from BIOS.

Output from efibootmgr:

BootCurrent: 0005
Timeout: 1 seconds
BootOrder: 0005,0002,0006,0004
Boot0002* Hard Drive    BBS(HD,,0x0)0000474f00004e4fc3000000010000008100530061006d00730075006e006700200053005300440020003800370030002000510056004f00200031005400420000000501090002000000007fff040002010c00d041030a0000000001010600020101010600000001010600000901010600000003120a000100ffff00007fff040001043e00ef47642dc93ba041ac194d51d01b4ce6350053005600530046004e004e00300037004200330034003600300020004c00200020002000200000007fff04000000424f
Boot0004* USB   BBS(USB,,0x0)0000474f00004e4f61010000010000004501200055005300420000000501090005000000007fff040002010c00d041030a000000000101060002010101060000000101060000080101060003000305060008007fff040001040601ef47642dc93ba041ac194d51d01b4ce630003400300031003000620039006400620037003200320038006200380034006600320035003500380062003100310036006500330037003300370030003200640066006400370035003700340061006500650032003700610063003600360035006100350034006100650063003300320061003200300062006300640065003700640066006200300030003000300030003000300030003000300030003000300030003000300030003000300030003000300065003500310036006300300066006600310031006200300031003800380031003500350038003100300037003200320061006300330062003000360000007fff04000000424f
Boot0005* UEFI:  USB    PciRoot(0x0)/Pci(0x1,0x2)/Pci(0x0,0x0)/Pci(0x8,0x0)/Pci(0x0,0x3)/USB(8,0)/CDROM(1,0x7c445c,0x8000)0000424f
Boot0006* UEFI:  USB, Partition 2       PciRoot(0x0)/Pci(0x1,0x2)/Pci(0x0,0x0)/Pci(0x8,0x0)/Pci(0x0,0x3)/USB(8,0)/HD(2,MBR,0x0,0x7c445c,0x2000)0000424f

I can change the boot order from BIOS, but i don’t think that is the issue here, GRUB failed to install so boot fails if I boot form hard drive. Live USB is currently only bootable drive.
Edit: the one slightly unnerving thing about this is that the first ubuntu install I tried didn’t have windows 10 listed as an OS on my computer. Last time i did this it said this computer has win10 and ubuntu on it, and then asked me what i want to do, but this time I only got ubuntu listed.

Gosh. First, I would advise you to educate yourself of the difference between BIOS and UEFI. Both do the equal job, but are not compatible to each other. Moreover, MS-DOS/MBR and GPT.

Right now, you boot in UEFI mode:

Otherwise, there would be written BIOS: or UEFI[Legacy]:. And it seems you tried to install it that way, since there is an EFI partition:

Don’t mix it. If you start with BIOS/legacy, then stay on it.

If you don’t want to change the whole partition scheme to GPT, what also means in general a complete wipe, you would need to boot the Manjaro Installer ISO in legacy mode. Note that on MS-DOS/MBR only one bootloader per drive can be targeted. So the last installation will always overwrite the MBR (Master Boot Record).

Yes, you are screwed, but no it is fixable. You need to reinstall grub in BIOS mode again. That is a good summary about it: GRUB/Restore the GRUB Bootloader - Manjaro

Oh right, sorry, I sometimes still call the UEFI the BIOS by habit.

I installed Ubuntu 22.04 initially about six months ago using the standard live ISO USB which actually exited with the same error of being unable to write GRUB to the drive and killing all my boots. However what fixed the issue last time was simply trying again and this time pressing “try ubuntu” instead of installing it right away. This gave me more options and installed perfectly. Naturally this time I thought it might work but nope, whichever way I sliced or diced it it wouldn’t write GRUB. I thought it was Ubuntu installer since it is known to be buggy but either there is some other problem or I have so many failed Ubuntu and Manjaro installs that the boot partitions are messed up a bit.

I don’t intend on changing my drive filesystem, I didn’t ever change the filesystem type, I simply followed the inbuilt options to install alongside my other OS/OSes. Yes there are lots of partitions with no functional purpose anymore and I really don’t know what to do/what the difference is to last time when it installed fine (after getting this very same error once only).

Edit: I think the efi partition you point out is left over from the first Ubuntu dead install which got overwritten with a functional Ubuntu install about six months ago. My reasoning for this is because I just used the default installer and just pressed to install alongside windows 10 and let the installer take care of the rest. I did actually have a hard time working out if it was needed or not, so I kept it just in case. I think the Ubuntu was installed in UEFI mode (my system is UEFI, and I just used the installer and let it do its thing) and that the efi partition is useless however I am not certain. My reasoning for this is because I just used the default installer and just pressed to install alongside windows 10 and let the installer take care of the rest. Is there anything in the data I have given that would indicate one way or the other?


Maybe that is not specific enough. Your UEFI has a bootloader with a basic boot menu. That can be called in numerous ways. Normally, you can make it visible by entering F11 or another Key on boot time. If you have a bootable drive connected, then it should show your drive with 2 entries for both modes.

Usually you can check it like this:

test -d /sys/firmware/efi/efivars/ && echo "EFI" || echo "BIOS" 

If there is such a path, then you are in EFI mode. If it is not there, then you are in BIOS mode. Simple.

Since your drive is preformated with MS-DOS and not GPT, you need always to use BIOS, not EFI.

Okay, thanks. Will check that in a few hours time.
Last thing for now:

Blockquote Usually you can check it like this:
test -d /sys/firmware/efi/efivars/ && echo "EFI" || echo"BIOS"

Where should I run this command? In the legacy mode Manjaro console?

Yes, you would need to run this command in a terminal. It will tell you quickly in which mode you are. The Installer also tells you that. Example here:

Okay, I ran the command, it tells me I am definitely in UEFI mode. How do I boot the Manjaro ISO in legacy/BIOS mode? I have opened the boot menu which shows all boot devices, here is what it lists:

AHCI: Samsung SSD 870 QVO 1TB

I don’t see a BIOS option there, unless it is actually once you boot the manjaro ISO? I checked that and I didn’t see one.
I’ve just gone and read the compatibility with Windows boot support, which only supports BIOS with MBR or UEFI with GPT.

Obvious to me: UEFI: is EFI and anything else is BIOS.

Okay. I booted into the USB using the USB option that did not have UEFI next to it (I presume this is how I get into the manjaro legacy), and the manjaro that comes up is behaving strangely. It first brings up the normal options like boot with open source or proprietary, boot setting, etc. However, if I hit the down arrow it goes down to the bottom of the list pretty much instantly. Same with the up arrow. It seems to be registering my keyboard arrow inputs every frame they are held down. It crashes consistently after a few seconds of showing this screen. Well I assume it is a crash, the screen freezes and does not unfreeze, and I have to turn it off. I have yet to be able to get into the boot with open source or the boot with proprietary option due to this unusual behaviour. The regular manjaro works flawlessly and does not display this unusual behaviour. What to do?

Edit: I got in, it is installing, I will let you know the result.
Edit 2: aha! success! everything works as intended, my win10 is back, etc etc etc.

That is due to the grub theme and the limitations of the legacy mode. Anyway, I would recommend using UEFI if all installed OS support it. I really wonder why it came with Windows 10 installed in pure BIOS from the factory. Nowadays, it is recommended to use UEFI and only if necessary using BIOS/CSM/legacy. It is much more flexible anyway, especially when working with a dual boot.

However… disabling Compatibility Support Module, SecureBoot and FastBoot is the first thing I do on my Linux computers.

Great. :+1:

This is a custom pc, nothing was installed on it from the factory. I installed it myself. I had to update the BIOS but it worked fine. I am not sure that the windows was in BIOS but if you really think so then I can believe it. It works, however now booting from hard drive the GRUB bootloader does load but it does the same crap it did in the live USB, the boot screen arrow keys are not functioning properly and it almost instantly crashes (no 10 sec leeway to try and luck out and hit the right one). I am not going to deal with this every time I boot up my computer. Any suggestions? Also is there any way to get everything back to the UEFI mode? Since you said these boot screen annoyances are a limitation of BIOS, surely I would want UEFI, right? It never did this silly stuff before.

Edit /etc/default/grub and comment (#) GRUB_THEME out. Then update-grub. As said, the theme is not made for BIOS.

Backup important data, wipe everything, disable CSM and install everything in UEFI mode. :man_shrugging:


Really??? Cannot believe that. That happened on any computer which was running in BIOS mode.

I have had the dualboot with ubuntu for about 6 months and the boot screen never did anything strange, it behaved completely perfectly like the manjaro non-legacy boot screen does.

Yeah, Ubuntu has the stock minimal grub theme. Sure that works.

Updated GRUB so that the theme is gone, now it looks very similar to the Ubuntu boot except it still does that weird thing with the keyboard and crashes almost immediately every single time, so not any better in that regard. Any other ideas?

Edit: Fixed, looks like for whatever reason it only does this if the hard disk boot is manually selected. Removing the live USB and letting the BIOS find that no USB device was plugged in and so it boots form the hard drive next works just fine.