Deactivate push notification for package updates

Hello there,
This might be a minor thing but it still annoys me extremely. I have never found out how I can deactivate gnome from showing me push notifications from the package manager, like these:
image

One would think this is a standard thing so I checked the Internet and also the notification tab of the gnome settings but did not find anything.

Does somebody know a trick to deactivate it, either via terminal or in fact in the UI somewhere?

Thanks in advance

They’re not push notifications. It’s part of the pamac-gnome-integration package, and it periodically checks the mirrors for updates.

Well, I don’t use GNOME, but I would expect that you can right-click the icon and change its settings there. :man_shrugging:

2 Likes

I am on XFCE and i actually want such popup but it is only working from time to time.
Generally speaking: you have the setting in pamac to auto check for updates or not, you have the startup process pamac-tray you can disable, or you can go in the tray settings and hide the icon.
But i think this is not what you ask.

2 Likes

Open the Add Remove Software application - go preferences and disable check for updates - or you could set it to notify once a week.

Remember to disable AUR as well so you do not get notification on script changes.

If you want to remove it completely - remove the mentioned package

sudo pacman -R pamac-gnome-integration
2 Likes

Thanks for your answers! I just did the last thing and deactivated it. I then didn’t get the nasty popup again while running updates

Thank you!

1 Like

So as to spare any newcomers happening upon this thread from having to read the whole thread looking for the answer, could you please mark the post that helped you on your way as the solution? That way…

  • the solution will be added to the opening post; and
  • the thread will be automatically closed 48 hours after the last reply, which prevents it from getting necrobumped later.

Thank you. :wink:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.