Dbus or dbus-x11 with XFCE?

OP, thanks for posting this issue, I was wondering why as well after checking out Xfce from a long time using Gnome.

Using Dbus instead of dbus-x11 solves my issue of 20-30 sec delay on the rare cases of using a gui as root through pkexec or others.

@KrazyLurt You are welcome, at least, i know i am not alone :slight_smile: with this issue.

Anyway, it does not solve our problem. Well, dbus solved it, but i am wondering what are the differences with dbus and dbus-x11 and if it would be a good idea to replace the default dbus-x11 by dbus…as in the past (one year more or less), dbus what replaced by dbus-x11.

If anybody have information on that point…

On my Manjaro Gnome partition the default is dbus and not dbus-x11 so I agree, XFCE desktop enviroments using dbus-x11 maybe is not that good.

@Manjaro-Team Could you please give us your opinion on that point ?


good morning to all of you, I follow you attentively:
This also happens on my desktop xfce and cinnamon(not a problem therefore the desktop used) both with manjaro, however this does not happen in linux mint nor in EndeavourOS, both in a system as in the other where it does not occur, there are no “.xinitrc”, also I have been able to verify that in EndeavourOS, not even had the custom action thunar root, I had to create and once created worked perfectly, there was no delay when opening the desktop as root.

So in my opinion maybe there is some problem in the “.xinitrc” programming.

Greetings to all and say to the manjaro team that this is not even annoying for me, it has no importance, I just write this in case it is useful.
Happy Holidays to all

When it happens to you, do you have the same message in journalctl ? e.g :

20:01:37 chris org.freedesktop.FileManager1[218758]: Failed to register: Unable to acquire bus name 'org.xfce.Thunar'

and then 20-25 seconds for the next entry ?
Also, what do EndeavousOS or Mint use ? dbus or dbus-x11 ?
Just want to be sure it’s the same issue

dbus-x11 looks like a Manjaro mod. Arch and most probably, Endeavour use the Arch dbus. If you compare the PKGBUILD They are pretty similar except Manjaro’s dbus-x11 uses the following flag:

–enable-x11-autolaunch \

My Xfce install has been rolling for a good few years with dbus : No problems with custom actions

but dbus-x11 has been default on Manjaro for some time
Yet another Custom Actions Thunar question (but different this time)

I installed dbus-x11 to check it out and it is working with no delay problem

The only difference I can see is as already noticed – Thunar uses the same Compact View on my system as the non-root folders

I don’t see any point to discussing packages used on another distribution

1 Like

Maybe the issue is with the pkexec command that you are using in Thunar custom actions? Can you post the command that you are using?

Could it be it needs the full path? Something like this:

pkexec /usr/bin/thunar %d

1 Like

Please re-read my initial topic, i dealt with the post you pointed already.

Months ago, there was issues with dbus and manjaro changed with dbus-x11, which was fine with custom actions especially with pkexec.

Now, on my current system as well as with a fresh installation on another machine, some of us (including me) have issues and we had to revert to dbus for custom action with pkexec, which is in my opinion the best for root custom actions with Thunar as it opens another Thunar instance with a thick orange band at the top for safety.

So, we are happy to know we do not have any issue, but i created this thread to try to sort my issue out and not for having people saying : “Hey, by the way, i do not have any issue, so the issue does not exist”…yet, it does, period.

good morning and merry christmas to all
in my opinion you are absolutely right, as I said starting from a shutdown pc(only 1 time as you described) it is easy to check with the command $ >time pkexec thunar ,enter the password and wait for the thunar window to come up as root to close and see the time. as you described it takes 30 sec the first time then it acts normally.
You are also logically right that mint and endervourOs use dbus(dbus-x11 is signed by philm). So as I said for me it’s not even an annoying problem but I can see that you are right and that’s it. I won’t write anything more about it and will keep reading you, happy day ChrisCanyon.

Translated with www.DeepL.com/Translator (free version)

$ >time pkexec thunar

real	0m31,819s
user	0m0,213s
sys	0m0,027s
$ >

1 Like

Just to add some additional info: I was able to bypass the 20 sec startup for Thunar Root using dbus-x11 by installing xdg-su AUR

However, long-term the solution would likely be using the normal dbus package if there are no issues using it. dbus-x11 was provided as a workaround for functionality that was lacking in dbus at the time.

1 Like

Does anybody in charge on xfce release in the team could give us his opinion, please ?
dbus or not dbus, that is the question…

My opinion is not to use such features as Thunar root.

and why ?
Do you recommend to not use Thunar globally too ?

As a manjaro team member, i would except a little bit more involvement from you, as xfce is an official flavor.

I wrote my private opinion.
Sorry for not being able to meet your expectations.

1 Like

I’ll test with dbus again on my end …


good morning philm and happy holidays, I have to say that after the update this morning (9:51 Spanish time) thunar root works as expected from the beginning, ie responds in my case at the time of entering password, I ignore what would have been the change made, dbus-x11 is still installed on my system, I hope not to cause discomfort with the comment, it is only to report, thank you very much for everything.

Nombre                    : dbus-x11
Versión                   : 1.12.20-1
Descripción               : Freedesktop.org message bus system
URL                       : https://wiki.freedesktop.org/www/Software/dbus/
Licencias                 : GPL custom
Repositorio               : core
Tamaño de la Instalación  : 955,4 kB
Depende de                : systemd-libs expat audit libsystemd.so=0-64
Hacer dependencias        : systemd xmlto docbook-xsl python yelp-tools doxygen
                            git autoconf-archive xorg-server
Requerido por             : at-spi2-core avahi bluez chromium colord cups
                            dbus-glib dbus-python dnsmasq flatpak fluidsynth
                            ghostscript jack2 lib32-dbus libpcap libproxy
                            libpulse libteam light-locker manjaro-hotfixes
                            pipewire rtkit steam-manjaro systemd thunderbird
                            weylus-bin wpa_supplicant xdg-dbus-proxy
                            xorg-server zbar
Opcional para             : alsa-plugins
Provee                    : libdbus libdbus-1.so=3-64 dbus=1.12.20
Entra en conflicto con    : libdbus dbus
Empaquetador              : Philip Mueller <philm@manjaro.org>
Fecha de creación         : 08/07/20
Fecha de instalación      : 03/01/21
Motivo de instalación     : Explícitamente instalado
Firmas                    : Sí

This is what happened something like 1 year ago, dbus-x11 worked as it should, then, about 3 months ago, there was this issue with Thunar root.

I imagine it happened after an update at this time. I did not yet updated my system with the latest stable update, but it’s not impossible that it works again with dbus-x11 now