Davinci Resolve no supported GPU processing mode / no GPU detected

Hi there,
first of all: I am fairly new to using Linux as my home pc. I work a lot with SUSE servers so I am not a complete dull.

I want to use Davinci Resolve and the installation goes fine but then the message pops up
“Unsupported GPU Processing Mode”
When I go into the configuration it looks like Davinci does not detect my GPU
under Memory and GPU I can switch to manual GPU selection but there is no GPU listed. Also I cant change the GPU processing mode (there is nothing in the drop down list)
mhwd -li:

Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

      video-nvidia            2021.11.04               false            PCI

Warning: No installed USB configs!

So far I tried some messing with the configuration but now luck. A fresh install also did not do the trick …

My System
R7 3800X
32GB 3200Mhz
Gigabyte 2080 Super
Gigabyte B450 Aorus Elite


PS I dont know how to post screenshots here as the forum tells me “Sorry you cant embed media in a post” :confused: or “Sorry you cant post links in a post” maybe I am too fresh for this forum

Hi @apfelimkuchen and welcome :wink:

Davinci Resolve needs cuda aswell. Did you install it?

Hey @megavolt,
Thank you very much.
I did not had cuda installed but I did now - I got cuda [NVIDIA’s GPU programming toolkit] and cuda-tools, but still I can’t change the GPU processing mode nor does my GPU turn up in the settings :confused:
Thanks for your time!


Have a look at this wiki article: DaVinci Resolve - ArchWiki
Is opencl-nvidia also installed?

1 Like

Hey @megavolt,
Thank you for your time!
Now it works.
To sum it up:
I installed as you said opencl-nvidia - there was a problem with what I had installed (“opencl-nvidia and opencl-nvidia-470xx are in conflict.”) so I deinstalled that one and installed the one you mentioned.

And I took a look at the davinci resolve checker script it told me then everythings good to go, so I fired it up and voila it works now!

Thank you very much
Have a good day :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.