Dash to Panel theme background color defaults to black each reboot

Since the stable update to Gnome 40 Dash to Panel reverts to black each reboot, despite custom color settings.

Should be fixed with version 43 in community repo…

But it’s not.

Everytime I log in I have to go to Dash to Panel settings, then Style and disable and re-enable the Override panell theme gradient.

In my Gnome its working for some weeks now.
But I come from Unstable switching to testing to save nerves.

Please look for:
/home/(username)/.local/share/gnome-shell/extensions/
If exists: dash-to-dock@micxgx.gmail.com
that´s the reason why you have problems.
Then un-install dash-to-dock by “extension”-app (works with Gnome3.38)
and install the version in pamac: “gnome-shell-extension-dash-to-dock 69+14+g302c693-5”
(This Version only works with Gnome40)
If you have both installed, the version in your profile and the version from pamac,
the version in your profil will be loaded, and this version from extensions.gnome.org
is not forgnome40.
The “Pamac-version” will work after reboot!

I’m speaking of Dash to Panel while you are refering to Dash to Dock.

Sorry. But all the same: DtP 43 is the working version in gnome40
I use both… :hot_face:
Shure you have no DTP in your home-directory and version installed by pamac?
or
https://github.com/home-sweet-gnome/dash-to-panel/releases/tag/v43

I’m sure. The only one I have installed is v43, from the Official Repos

My working Version is:

I am currently using the same version. The issue persists.

The last possibillity will be to reset Gnome…
.
Rename in nautilus: ~/.config/dconf/user
or via terminal:
mv ~/.config/dconf/user ~/.config/dconf/user.bak
… and reboot.
.
Gnome will be reset to default…
.
If you want the old gnome-config back:
cp -f ~/.config/dconf/user.bak ~/.config/dconf/user
This overwrites the “new” config with the old one…
Reboot after this, otherwise gnome saves the current config.

Version “43 (67b19…)” is COMPLETELY different from “Version 43-1”
(means is something else, not the same, like pi-tbull and pi-nscher) :innocent:
((“43 (67b19…)” NOT EQUAL "43-1))

It’s the latest available version in the official repositories.

This is correct, but not helpful. Ich bin nicht der Rätselonkel! How to make senseful responses??
As I am no telepath → I cannot help you. Finished. No further reply

The issue was resolved, somehow accidentally, by installing this extension.

Simpler:
Extension Dash to Panel - config - third tab from the left:
“Disable show overview on startup”.

1 Like