Dash to dock -->stroke line around the dock

Hi all,
i’ve been searching for this issue in case someone had it before but could not find results, hope someone can help me.

I have the extension dash to dock enabled and for some reason there’s a white stroke line around the upper+lower+right side of it (not left or bottom), several pixels above the dock itself.
I’ve tried playing with the configuration of the extension and there’s nothing there to remove it.
Even removed it and re-installed in case there would be a config file somewhere but i cannot get rid of it.
I’m using the “Orchis dark theme” for gnome. I thought it was a problem with the theme, so i tried different ones.
I see the same issue with Adwaita and Matcha, but not with Adapta or Arc darkest.
In the last two the dock is square and bigger so it “covers” the place where i see the stroke line, while the others are smaller or roundish.

The thing is i have a virtual machine where i did download the latest version of manjaro gnome and installed orchis dark, there i don’t see this line around the dock with this or any other theme.
If i recall correctly this started happening when gnome was upgraded to v40, i thought it was because initially the extension was not supported in gnome 40, but it does work on another installation and it does have support now.

I found a stylesheet.css file in the extension folder:
Replaced it with the one in the virtual machine and restarted but same line appears.
I’m a bit lost on how to solve this, if someone can shed some light or give me any hint i would appreciate it.

Some info on the system:

  Kernel: 5.14.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  Desktop: GNOME 40.5 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1
  Distro: Manjaro Linux base: Arch Linux


You can change the look of the dock by editing the css file in the gnome shell folder, of your theme’s folder.

Not sure if this will help? Maybe put the theme that works on VM on the physical computer to see if that helps.

I use Orchis Dark exclusively and can neither reproduce it on GNOME 40 nor 41. Make sure you’re installing the theme from the latest commit whether using the orchis-theme-git AUR (Arch User Repository) package or installing it directly from source as a user theme.

Also, it sounds like you haven’t disabled Use built-in theme in Dash to Dock settings under Appearance.

yes that’s what i did, replaced the .css file from the theme that works in the virtual box to the theme in the real installation.
Did not work, i also tried to change the .css manually but i’m not sure what is the line that would control this, in any case using the other .css did not solve it anyway and on the other install it shows properly.
So i guessed it was not related to that file.

In both cases i’m installing orchis-theme-git via pamac from AUR, i checked and turns out the version that pamac displays is different.
Install without the stroke line: 2021.10.16.r6.ga019035-1
Install with the stroke line: 2021.10.16.r0.g18811c4-1

I uninstalled it, refreshed the mirror list, the database and looked for it again in AUR i see the same version to install as previously, i’m more confused now…
How can i install different versions of the same package with the same installation software on different installations of the same OS?
Is this a bug in the version shown in pamac?
Also if i visit the AUR page on the link provided on both installations it leads me to the same page where it does state the same version for both installations: 2021.10.16.r0.g18811c4-1

I went to the theme author page in github, downloaded the latest release and installed it manually, still having the same stroke line.
Removed it and turned back to the installation from pamac – AUR

In the dash-to-dock extension “Use built-in theme” option was disabled, however i also tried to turn it on and offto see the effect, it does not remove this. Just matches the style of the background of the dock, i prefer the other as it has more transparency but the line remains.

Starting to think this is not theme related but “dash-to-dock” extension related.

Dash to dock extension is the same version in both installations, but i did notice the author published a newer one (v70 for gnome-shell 40), i tried to install it downloading from his page and installing manually, still the same.

Think i will post a “bug” on github to see if i can get some help there, that’s the communication channel he proposes on his website.
Thanks for your comments, it allowed me to test few things i did not think of.

The current version is 2021.10.16.r6.ga019035-1. The last time the PKGBUILD was updated was 2021.10.16.r0.g18811c4-1. If nothing changes upstream, the PKGBUILD never needs to be updated. That’s how VCS packages work. It always pulls the latest commit when built.