Dash to Dock not working after update

Hi,

i have updated a fresh install of manjaro gnome with toolbox.
The das to dock no longer works after the update. The extension manager shows the following error:

The settings of extension dash-to-dock@micxgx.gmail.com had an error:

GLib.FileError: Datei »/usr/share/gnome-shell/extensions/dash-to-dock@micxgx.gmail.com/schemas/gschemas.compiled« konnte nicht geöffnet werden: open() ist gescheitert: Datei oder Verzeichnis nicht gefunden

Stack trace:

getSettings@resource:///org/gnome/Shell/Extensions/js/misc/extensionUtils.js:200:31
_init@/usr/share/gnome-shell/extensions/dash-to-dock@micxgx.gmail.com/prefs.js:188:45
buildPrefsWidget@/usr/share/gnome-shell/extensions/dash-to-dock@micxgx.gmail.com/prefs.js:1013:20
_init@resource:///org/gnome/Shell/Extensions/js/extensionsService.js:219:40
OpenExtensionPrefsAsync/<@resource:///org/gnome/Shell/Extensions/js/extensionsService.js:128:33
asyncCallback@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:115:22
run@resource:///org/gnome/Shell/Extensions/js/dbusService.js:177:20
main@resource:///org/gnome/Shell/Extensions/js/main.js:19:13
run@resource:///org/gnome/gjs/modules/script/package.js:206:19
start@resource:///org/gnome/gjs/modules/script/package.js:190:8
@/usr/share/gnome-shell/org.gnome.Shell.Extensions:1:17
1 Like

That shouldn’t be happening and I can’t reproduce it. Try uninstalling / reinstalling it:

It’s required by manjaro-gnome-assets, so we’ll temporarily yank it:

sudo pacman -Rdd gnome-shell-extension-dash-to-dock

Reinstall it while making sure you’re up to date:

sudo pacman -Syu gnome-shell-extension-dash-to-dock

Also make sure you don’t have it installed twice. Open the Extensions application and make sure Dash to Dock is only listed under Built-In, not Manually Installed. If it is, remove it.

I’ve installed twice from manjaro-gnome-21.1.6-211017-linux513.iso and both times the same.

your advice worked! But needed to restart after removing the dock because it was still in extensions with the error message.
I needed to restart again after reinstalling it and now it works perfect.
Thanks a lot!

If you’re using a Wayland session, you only need to log out / login. In a Xorg session, you can just restart GNOME Shell by pressing Alt+F2 and typing r then Enter.

I installed Manjaro Gnome today and I too had the same problem. Just go to the add/remove software app, search for gnome-shell-extension dash to dock, re install it and don’t forget to restart the PC after.

I have installed Manjaro on another machine and same issue.
Your way fixed it faster.

But maybe someone should fix the broken update, not every new user is reading here :slight_smile:

The update is not broken, one just needs to restart GNOME Shell / log out as described above. That should always be done when an extension is updated.

Update: @philm and I figured out the original underlying issue. manjaro-gnome-extension-settings 20211210-1 will resolve it for new installs.

We’ll also be working on other improvements and there will be further extension related updates soon.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.