Dark theme not working in Dolphin after Manjaro update

Two days ago I updated Manjaro, as I normally do whenever there is a major update. Apparently, everything went smoothly, but after rebooting, the dark theme I’m using is not working in Dolphin (and other applications, such as Spectacle) anymore.

Other apps, such as System Settings, Firefox, Thunderbird, or Gimp (just to name a few) are fine.
I checked and all themes (Application Style, Plasma Style, Colours, Window Decorations, Icons, Cursors, and Splash Screen) are up to date.
I retried using them, but the problem persists.

My theme configuration
Global Theme: WhiteSur-dark
Application Style: kvantum
Plasma Style: WhiteSur-dark
Colours: WheteSurDark
Window Decorations: WhiteSur-dark
Icons: McMojave-circle-dark

Moreover, I am noticing that the system is “sluggish” after the update. For instance, the System Settings crash sometimes, Dolphin is noticeable slower, as well as Latte Dock. Inspecting the CPU load, I realise that the four cores are always above 30%, easily attaining approximately 100% with basic apps on (Thunderbird, RStudio, or VSCodium).

I already rebooted the computer several times, but the aforementioned issues persist.
Any hint on how to solve these problems?

Here is the output of inxi -Fazy:

Kernel: 5.14.7-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64 
root=UUID=7237cc4d-9ab7-410c-90c4-b8c90e2b10df rw quiet apparmor=1 
security=apparmor udev.log_priority=3 
Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 
dm: SDDM Distro: Manjaro Linux base: Arch Linux 
Type: Laptop System: LENOVO product: 4180Q3U v: ThinkPad T420 
serial: <filter> Chassis: type: 10 serial: <filter> 
Mobo: LENOVO model: 4180Q3U serial: <filter> UEFI-[Legacy]: LENOVO 
v: 83ET82WW (1.52 ) date: 06/04/2018 
ID-1: BAT0 charge: 24.1 Wh (100.0%) condition: 24.1/56.2 Wh (42.9%) 
volts: 12.4 min: 10.8 model: SANYO 45N1001 type: Li-ion serial: <filter> 
status: Full 
Info: Dual Core model: Intel Core i7-2640M bits: 64 type: MT MCP 
arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F 
cache: L2: 4 MiB 
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 22333 
Speed: 1514 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 1514 2: 2022 
3: 3249 4: 2194 
Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
Type: l1tf mitigation: PTE Inversion 
Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
Type: meltdown mitigation: PTI 
Type: spec_store_bypass 
mitigation: Speculative Store Bypass disabled via prctl and seccomp 
Type: spectre_v1 
mitigation: usercopy/swapgs barriers and __user pointer sanitization 
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
IBRS_FW, STIBP: conditional, RSB filling 
Type: srbds status: Not affected 
Type: tsx_async_abort status: Not affected 
Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
vendor: Lenovo ThinkPad T420 driver: i915 v: kernel bus-ID: 00:02.0 
chip-ID: 8086:0126 class-ID: 0300 
Device-2: Chicony integrated camera type: USB driver: uvcvideo 
bus-ID: 1-1.6:6 chip-ID: 04f2:b221 class-ID: 0e02 
Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
loaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
Screen-1: 0 s-res: 1920x2100 s-dpi: 96 s-size: 507x554mm (20.0x21.8") 
s-diag: 751mm (29.6") 
Monitor-1: LVDS-1 res: 1600x900 hz: 60 dpi: 131 size: 310x174mm (12.2x6.9") 
diag: 355mm (14") 
Monitor-2: DP-3 res: 1920x1200 hz: 60 dpi: 94 size: 518x324mm (20.4x12.8")
diag: 611mm (24.1")
OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2)
v: 3.3 Mesa 21.2.2 compat-v: 3.0 direct render: Yes
Device-1: Intel 6 Series/C200 Series Family High Definition Audio
vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1c20 class-ID: 0403
Sound Server-1: ALSA v: k5.14.7-2-MANJARO running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.37 running: yes
Device-1: Intel 82579LM Gigabit Network vendor: Lenovo ThinkPad T520
driver: e1000e v: kernel port: 5080 bus-ID: 00:19.0 chip-ID: 8086:1502
class-ID: 0200
IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
v: kernel port: efa0 bus-ID: 03:00.0 chip-ID: 8086:0085 class-ID: 0280
IF: wlp3s0 state: up mac: <filter>
IF-ID-1: wwp0s29u1u4i6 state: down mac: <filter>
Device-1: Broadcom BCM2045B (BDC-2.1) type: USB driver: btusb v: 0.8
bus-ID: 1-1.4:4 chip-ID: 0a5c:217f class-ID: fe01 serial: <filter>
Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
Local Storage: total: 1.36 TiB used: 1.04 TiB (76.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: <filter> rev: 3B6Q scheme: MBR
ID-2: /dev/sdb maj-min: 8:16 vendor: HGST (Hitachi) model: HTS541010A9E680
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 5400 serial: <filter> rev: A7G0 scheme: MBR
ID-1: / raw-size: 65.37 GiB size: 63.84 GiB (97.67%) used: 46.96 GiB (73.6%)
fs: ext4 dev: /dev/sda1 maj-min: 8:1
ID-2: /home raw-size: 400.39 GiB size: 393.11 GiB (98.18%)
used: 284.96 GiB (72.5%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
Alert: No swap data was found.
System Temperatures: cpu: 78.0 C mobo: N/A
Fan Speeds (RPM): cpu: 4527
Processes: 274 Uptime: 7h 58m wakeups: 2 Memory: 15.52 GiB
used: 7.45 GiB (48.0%) Init: systemd v: 249 tool: systemctl Compilers:
gcc: 11.1.0 clang: 12.0.1 Packages: 2150 pacman: 2142 lib: 440 flatpak: 0
snap: 8 Shell: Zsh v: 5.8 running-in: konsole inxi: 3.3.06

If I start Dolphin from any launcher (Latte Dock, Launchpad Plasma, or Application Launcher), the theme is OK! Only when I use the keyboard shortcut to start the app I get the wrong theme. The same goes for Spectacle: if I press the “PrtSc” key, the theme is wrong; if I call the app from any launcher, the theme is OK.

  1. Have you tried creating a new user and logging in there and see if it happens there too? (E.G. nunonun2
  2. If yes, sounds like you need to file a bug with the theme developer.


i see that it’s mostly the title bar that is white,so maybe it’s similar to this:

the solution for me was to re-apply the Colors theme section.

1 Like

Thanks for your reply, @Fabby.
I created a new user, but everything works fine, there. So, I think the problem is not on the theme side.

So you have an issue in your user profile and finding out which exact setting you changed is going to take weeks if not months, therefore, we’re going to do the following:

  • Verify that the new user has access to the same groups as your old one by executing groups and comparing the output of both users.

    groups twitty
    groups twitty2

    (Where obviously, twitty is your old user and twitty2 is your new one.)
    E.G. if twitty is a member of operator and twitty2 isn’t, execute:

    usermod --append --groups operator twitty2
  • Copy all data files from your old profile into your new one

    cp --verbose --recursive --preserve=timestamps /home/twitty/Documents/* /home/twitty2/Documents/

    If that worked and you had no errors, remove the documents from your old user:

    rm --recursive /home/twitty/Documents/*

    repeat for:

    • Pictures
    • Videos
    • Music
    • .thunderbird
    • .mozilla/firefox/
    • Templates, and everything else that is important to you.
    • Linux games like Battle of Wesnoth have their game data stored under ~/.local/share/ E.G. ~/.local/share/wesnoth/
  • After everything has been copied over, disable the old user so you cannot accidentally log on to it any more:

    usermod --lock twitty
  • If you would have theming or other customisations going on, don’t do everything in one day but do this at the rate of 1 application / theme / … per day and if the same issue crops up again, roll back your last change and thus you’ve now pinpointed the exact setting that made your old user misbehave. :thinking:

  • in 1 month delete the entire home directory of your old user, but don’t delete the user itself so that in 6 months time files still owned by that user will still show up under its username.

  • If you ever migrate to a new machine, just don’t migrate the old user: only the new one.

  • From now on, start making backups so you can roll back and never have to do this again:

1 Like

Hi @linub, thanks for your suggestion. Unfortunately, that did not solve the problem. I had already re-applied all the relevant sections underneath Appearance, without any avail. I re-did it, but it still does not work.
In the link you sent me, one of the proposed solutions is to downgrade manjaro-kde-settings. However, I do not have the previous version in my cache. I’m using version 20210813-2. Is there a way to get and install the previous version?

1 Like

Thank you, @Fabby. It’s a pity there isn’t a simpler solution, but I’ll do as you suggest.
All I can say is that this weird behaviour of a bad theme associated to apps when launched using the keyboard shortcuts started after I updated Manjaro and rebooted the system. I don’t remember having installed any particular software in the previous days and I didn’t modify anything in my configurations, as far as I can tell.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.