Dark mode broken

Today I brought my Manjaro up-to date. After that, the theming/dark mode seems to be broken. Many apps now appear in the default (light) style, although I selected “Dark” in the Gnome settings.

E.g. Pacman and the Terminal are light now. Nautilus on the other hand still appears dark.

I tried to solve the problem by switching back and forth between Default and Dark mode, and also rebooted several times. But the problem still persists.

Add/Remove Software (Pamac) and GNOME Terminal are both Gtk 3 applications. Set the Legacy Application theme with Tweaks under Appearance.

In order for both Libadwaita applications (like Nautilus) and Gtk 3 applications to switch between Default & Dark in Settings > Appearance, make sure you have the Legacy (GTK3) Theme Scheme Auto Switcher Extension (gnome-shell-extension-legacy-theme-auto-switcher) installed and enabled.


That’s the solution. With the Manjaro update this setting seems to have gotten lost.
After changing Tweaks → Appearance → Legacy Applications back to Adwaita Dark, all apps now appear in dark mode again.

Thank you very much!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.