Custom Shortcuts Won't Record New Key Bindings

Just had an update and now when I go into
System Settings / Shortcuts / Custom Shortcuts
I can add a new a new shortcut but on the Trigger tab, clicking on the button for Shortcut won’t record the key press.

I restored the system from a TimeShift back up and it works fine until I run the update again and then it stops working.

System: Kernel: 5.10.2-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=036aa914-36a5-4db7-909b-b36c0a5d104b rw
quiet udev.log_priority=3
Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Can anyone offer a suggestion?


Common plasma weirdness:

Well, apparently there is a know bug regarding this issue.

Bug 430388 - Custom Shortcuts cannot record key presses

It shows as Status: RESOLVED FIXED but that’s not what I’m seeing… anyway…

There is a work-around posted:

All you do is to go to the System Settings > Shortcuts, and on the search field you look up the custom shortcut you need to add/change. On the results box, press the desired result and click the corresponding buttons either to add/change shortcut or to add another. Your shortcut combination will now be registered and accepted.

Hopefully this saves someone else the headache.

Thank you for the suggestion. I read through that pretty thoroughly and even tried many of the suggestions but none of them worked.

But again, thank you for pointing that out to me. By reading through it I learned a few things (and a few commands) that I didn’t know.

Wow, you found a bug. She’s dead, Jim.

Annoyingly I was prompted to sort out a couple of shortcuts by your post, and now they won’t work.

Let’s try the workaround… I can’t find the custom shortcut name from the search field… though I have easystroke, so I have the script assigned to a gesture which serves… but I wanted to fix my Music to ‘tools’ (music key) and my Plex Media Player to ‘Alt+Tools’.

I tracked the config file down ~.config/kglobalshortcutsrc but I don’t see an easy ‘edit’.


The way that I did it (it’s a two step process) is to go into Shortcuts / Custom Shortcuts and then create a new shortcut. You won’t be able to assign the key binding right away, but that will come latter. The trick (in my case) was to name it something that would be easy to find. I would call it JUST PLAY MUSIC and then save it. Then, go back to Shortcuts and do a search on JUST PLAY MUSIC. In my case, when I search on that, what comes up in the search is System Services / Custom Shortcut Services. When I click on that, in the right hand pane JUST PLAY MUSIC shows and at that point you can then assign the Key Assignment you want. If you want, you can go back to Custom Shortcuts and rename the assignment (click on the name JUST PLAY MUSIC and press F2) and name it whatever you want.

Hope that makes sense and helps.


Yes, indeed it works. I had a problem with it before as my shortcut (made with my old keyboard and my recently returned SSD) looked at a changed folder (familiar, but wrong path).

Indeed this does work, thanks… though I’ll keep F2 for renaming :wink: I put Plex + Music on Fn-F5 and Fn-Alt+F5 and then mapped ‘sleep’ (strangely omitted on the Mk345 Logi keyboard) to Ctrl+ScrollLock.

Much better now.

This does not work for me…
When i do the search for the custom naming it does not show at all.

I just got into Linux and was going to try it out… it’s tiresome to see that i already have problem with these kind of problems.

These kind of problem is so small yet so annoying. Basically in my try to change the keybinding from bringing up the console, cant recall the default value but in my attempt to change it i made it to none and now i cant even have the basic shortcut to get up the terminal.

As a beginner this sucks.

What can i do?

Well certainly think a lot before changing shortcuts, there are sooo many and ‘Ctrl Alt T’ is muscle memory, definitely don’t change that one.

I’m running KDE right now, so let’s have another go…
I hope you still have the ability to open your menu :wink: for me that’s Meta+z, then type ‘shortcut’ and it should bring up your settings window with ‘Shortcuts’ and ‘Custom Shortcuts’ in the left panel.

Now you didn’t specify which console you’re trying to bring up (basically, you should use CTRL+ALT then press F2/F3 etc to change console, CTRL+ALT+F1 should bring you to your desktop.

Let’s make a Konsole launcher…
Custom shortcuts then, under the ‘Name’ list, right click and select ‘New…’ from the menu. I’m guessing a keyboard shortcut will do, so we’ll go with ‘Global Shortcut’ and then ‘command/url’.

Now you have a NEW action, to rename it, you can double click or click it and press F2 (edit) and type KON. That’s all, just KON.
Comment type ‘start Konsole’ and Action (Command/url) konsole

If you’re clever, you’ll launch a terminal and type which konsole' to get the path which is /usr/bin/konsole` on my system. You can enter that, but as it’s in $PATH it isn’t a problem.

Now click ‘Apply’. We have no shortcut yet…

Now click in the left panel, select Shortcuts and you’ll see Search…

Type KON, you’ll see in the middle panel, ‘Custom Shortcuts Service’. Select that.

NOW you can select a custom shortcut and it will work.

There you go :wink: I suggest stick with CTRL+ALT+T.

If you enjoy shortcuts, start also looking at mouse gestures (which can also trigger keyboard shortcuts).

For example, META+E launches Dolphin. On my system it launches the last session/folder… but if I do a mouse gesture ‘h’ it will open my ~ home directory. If I want the terminal open in that window (F4) I can draw a ‘4’ which executes the F4 function.

That’s nice, so my keyboard can sometimes be set with ‘function’ keys swapped and I can use gestures to do those functions, mouse thumb buttons to resize/grab-move windows, and all kinds of other stuff.

Small headaches, huge rewards dude :wink:

1 Like

Thanks, it works now

1 Like