Cursor theme choice in Xfce is without effect

Of the cursor themes listed in Settings > Mouse and Touchpad > Theme (hereinafter the “GUI setting”), as shown–


–only Adwaita, Breeze, and Breeze Light, when selected, go into effect (i.e. I get to see the icons as from Preview).

Choosing one of the other themes, e.g. Elementary, will just give me Breeze, which I believe is my default from seeing

  • /usr/share/icons/default/index.theme has Inherits=xcursor-breeze
  • /etc/lightdm/lightdm-gtk-greeter.conf has cursor-theme-name = xcursor-breeze


  1. When I choose a theme in the GUI setting, which configuration file am I editing?
  2. How could I fix the issue? I see this could take one of two forms: (a) Get the GUI setting to work or (b) bypass the GUI and edit some config file. Either way the desired result would be that I could use a cursor theme other than Adwaita, Breeze, and Breeze Light.

Things I’ve noticed or tried:

In several posts where the problem was a theme’s partial effectiveness (i.e. you sometimes see icons from a theme you did not choose), the fix involved the editing of /usr/share/icons/default/index.theme and /etc/lightdm/lightdm-gtk-greeter.conf:

But my problem is different. Certain themes are completely ineffective.

I tried creating a ~/.Xresources and entering:

Xcursor.size: 48
Xcursor.theme: Elementary

On reboot, I saw that the new size went into effect, but not Elementary.

Many of the ideas and links come from this earlier post: Incorrect cursor displayed in text editors


For anybody else similarly situated, here are the cursor themes involving neither problem (neither this post nor the other post’s) I’ve found:

I would guess elementary is for the elementary OS (pantheon DE) and wont work anywhere else.
(see also elementary variants of gtk themes)

Depending on which DMZ you are using … it is likely abandoned. I could not guess as to its effectiveness.

Simple-and-soft has been shown to be incomplete.

So … seems kinda normal to me.

To prove that theory, I downloaded oreo-grey-cursors.tar.gz from this page (the highest rated cursor theme from that site), extracted the contents into my /usr/share/icons/, saw Oreo Gray Cursors appear as a choice, chose it, and saw it go into effect.

So it worked. Thanks!

Only, this new theme also exhibits the “resize icon does not change to text insertion icon over text editors” problem from my other post.

So the only normal-working theme for me at present may be Adwaita.

What would be the crucial attribute of Adwaita (which makes it work normally)? In other words, how could I find other themes like Adwaita in this respect. @soundofthunder may have said Adwaita is from GTK.

This theme, or its “Simp1e-Adw-Dark.tar.xz” variant, was problem-free (maybe “Adw” is why): Simp1e Cursors - Eyecandy for your XFCE-Desktop -

I might add that, other than this Oreo, I did not download any of the other themes, i.e. they came with the OS install. I wonder at incompatible or abandoned themes creeping in that way.

And here’s something very odd. After testing of Oreo, I see that Simple-and-Soft is given some effect (e.g. the main pointer icon is that of Simple-and-Soft). So I thought perhaps I was being inattentive and did not notice that before. To confirm, I went to a VM in which no installing of a new theme took place, and there choosing Simple-and-Soft does not give me its main pointer. This whole area seems rather random.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.