Cursor size different on desktop and apps

Hi, my cursor size is different when it points on app and on desktop.

As the screen shot shows, the cursor on vscode and on desktop are in different size.

I’m on XFCE and system info are as follow:

[shore@shore-82wm manjaro_note]$ inxi -F
  Host: shore-82wm Kernel: 6.6.10-1-MANJARO arch: x86_64 bits: 64
    Desktop: Xfce v: 4.18.1 Distro: Manjaro Linux
  Type: Laptop System: LENOVO product: 82WM v: Legion R9000P ARX8
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76479 WIN
    serial: <superuser required> UEFI: LENOVO v: LPCN47WW date: 09/15/2023
  ID-1: BAT0 charge: 85.0 Wh (100.0%) condition: 85.0/80.0 Wh (106.2%)
  ID-2: hidpp_battery_0 charge: 100% condition: N/A
  Info: 16-core model: AMD Ryzen 9 7945HX with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 16 MiB
  Speed (MHz): avg: 2225 min/max: 400/5461 cores: 1: 3453 2: 400 3: 400
    4: 3652 5: 400 6: 3591 7: 400 8: 400 9: 3399 10: 400 11: 400 12: 4067
    13: 400 14: 400 15: 3452 16: 4335 17: 3353 18: 3448 19: 5126 20: 400
    21: 3458 22: 400 23: 3577 24: 400 25: 3908 26: 5176 27: 400 28: 4176
    29: 3462 30: 400 31: 3569 32: 400
  Device-1: NVIDIA AD107M [GeForce RTX 4060 Max-Q / Mobile] driver: nvidia
    v: 545.29.06
  Device-2: Syntek Integrated Camera driver: uvcvideo type: USB
  Display: x11 server: v: driver: X: loaded: nvidia
    gpu: nvidia resolution: 2560x1600~60Hz
  API: EGL v: 1.5 drivers: kms_swrast,nvidia,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
    renderer: NVIDIA GeForce RTX 4060 Laptop GPU/PCIe/SSE2
  Device-1: NVIDIA driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_rpl_pci_acp6x
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  API: ALSA v: k6.6.10-1-MANJARO status: kernel-api
  Server-1: PipeWire v: 1.0.0 status: active
  Device-1: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    driver: mt7921e
  IF: wlp4s0 state: up mac: a8:3b:76:73:83:77
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp7s0 state: down mac: fc:5c:ee:24:71:de
  IF-ID-1: docker0 state: down mac: 02:42:ac:34:5b:e1
  Device-1: Foxconn / Hon Hai Bluetooth Adapter driver: btusb type: USB
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 2.75 TiB used: 148.94 GiB (5.3%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVL21T0HCLR-00BL2
    size: 953.87 GiB
  ID-2: /dev/nvme1n1 vendor: Seagate model: WDC WDS200T2B0C-00PXH0
    size: 1.82 TiB
  ID-1: / size: 1.79 TiB used: 148.94 GiB (8.1%) fs: ext4 dev: /dev/nvme1n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 300 KiB (0.1%) fs: vfat
    dev: /dev/nvme1n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: 61.2 C mobo: 44.0 C gpu: nvidia temp: 38 C
  Fan Speeds (rpm): N/A
  Processes: 533 Uptime: 25m Memory: total: 48 GiB available: 46.73 GiB
  used: 10.99 GiB (23.5%) Shell: Bash inxi: 3.3.31

Hello @Shore :wink:

Is vscode running as flatpak? Then this might be the difference. You might need to add:


So that it uses the system cursor theme.

Hi thanks for replying. but I’m not really familiar with the system, so may I further ask:

  1. Is flatpak refers to the software flatpak? I didn’t install it
  2. Where I should put in XCURSOR_PATH=/run/host/user-share/icons:/run/host/share/icons


Well I just assumed that, since vscode is not in the official repo, but only code (code - OSS) and that one is not branded (top left icon).

Environment variable in flatseal for example, in case of using it as a flatpak,

Other than that, so probably AUR, the branded vscode must have somewhere a config, which sticks to a specific theme, not the system theme.

I use myself code, and have zero problems.

Hi, thanks.

I actually found that only vscode and edge has the problem. most of the other app does not act like that.

The packages I installed are visual-studio-code-bin and Microsoft-edge-beta-bin

May I further ask how I can make sure that my vscode is running as flatpak??

That pretty much indicates that these are AUR (Arch User Repo) packages. Unofficial and unsupported, you are on your own there normally. Manjaro can nothing do about that.

Check if that work:

 flatpak list --columns=name,application

PS: Switched the category to AUR :wink:

Thanks, the flatpak package is not installed

I may search if other platform has the same problem. thank you very much~~

Just mentioning…

The system cursor looks like xcursor-breeze and vscode cursor must be stock Adwaita.

I compared these two, both seems breeze, just size are different

I am not using XFCE, but SWAYWM. Probably this could help you:

File: $HOME/.config/gtk-3.0/settings.ini

gtk-font-name=Cantarell 11

Hi I simply added export XCURSOR_PATH=/run/host/user-share/icons:/run/host/share/icons under ~/.profile, it works

But it looks like Adwaita, may I ask how I can make it xcursor-breeze??

Thanks a lot

Hi, I put export XCURSOR_SIZE=16 in ~/.profile, it works~~~ thanks for your help

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.