Cursor moves in a grid-like pattern

Hello everyone,

I am having a very strange problem with Manjaro on my laptop. The cursor does not move smoothly, but rather it moves in steps, like it’s snapping to a grid along the x and y axes. I have found other reports of similar problems with (mostly) Lenovo laptops running Ubuntu.

My laptop is some sort of Samsung machine from around 2013. I got it off Craigslist just recently. It came with Windows 7 installed and the touchpad works fine in Windows, so it’s not a hardware defect. It also works fine with a USB mouse.

Any assistance is appreciated!

Maybe you will enjoy synaptics better?
Just install xf86-input-synaptics and see
(of course note that it comes with its own set of configuration and all that)

Please post

inxi -Fazy

Excuse the multiple edits - couldn’t get it to format nicely.

inxi -Fazy
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=bb0212a2-e4df-4b29-9cb4-9b33faa36a93 rw quiet apparmor=1 
  security=apparmor resume=UUID=45944897-2050-4f78-953a-c4fc6315aba5 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux

  Type: Laptop System: SAMSUNG 
  product: 355V4C/355V4X/355V5C/355V5X/356V4C/356V4X/356V5C/356V5X/3445VC/3445VX/3545VC/3545VX 
  v: P03ABF.006.CP serial: <filter> Chassis: type: 9 v: 0.1 serial: <filter> 
  Mobo: SAMSUNG model: NP355V5C-A04CA v: BOARD REVISION 00 serial: <filter> 
  BIOS: American Megatrends v: P03ABF date: 10/23/2012

  ID-1: BAT1 charge: 39.1 Wh condition: 48.8/48.8 Wh (100%) volts: 11.1/11.1 
  model: COMPAL PABAS0241231 type: Li-ion serial: <filter> status: Unknown 
  cycles: 83 

  Topology: Dual Core model: AMD A6-4400M APU with Radeon HD Graphics bits: 64 
  type: MCP arch: Piledriver family: 15 (21) model-id: 10 (16) stepping: 1 
  microcode: 6001119 L2 cache: 1024 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 10785 
  Speed: 1392 MHz min/max: 1400/2700 MHz boost: enabled Core speeds (MHz): 
  1: 1392 2: 1390 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 

  Device-1: AMD Trinity 2 [Radeon HD 7520G] vendor: Samsung Co driver: radeon 
  v: kernel bus ID: 00:01.0 chip ID: 1002:9990 
  Device-2: Silicon Motion WebCam SC-13HDL11939N type: USB driver: uvcvideo 
  bus ID: 3-5:4 chip ID: 2232:1029 serial: <filter> 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: radeon 
  FAILED: ati unloaded: modesetting alternate: fbdev,vesa display ID: :0 
  screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP res: 1366x768 hz: 60 dpi: 101 size: 344x193mm (13.5x7.6") 
  diag: 394mm (15.5") 
  OpenGL: renderer: AMD ARUBA (DRM 2.50.0 / 5.8.11-1-MANJARO LLVM 10.0.1) 
  v: 4.3 Mesa 20.1.8 compat-v: 3.1 direct render: Yes 

  Device-1: AMD Trinity HDMI Audio vendor: Samsung Co driver: snd_hda_intel 
  v: kernel bus ID: 00:01.1 chip ID: 1002:9902 
  Device-2: AMD FCH Azalia vendor: Samsung Co driver: snd_hda_intel v: kernel 
  bus ID: 00:14.2 chip ID: 1022:780d 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 

  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Samsung Co driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros AR9485 Wireless Network Adapter 
  vendor: Samsung Co driver: ath9k v: kernel port: e000 bus ID: 03:00.0 
  chip ID: 168c:0032 
  IF: wlp3s0 state: up mac: <filter> 
  Device-3: Qualcomm Atheros AR3012 Bluetooth 4.0 type: USB driver: btusb 
  bus ID: 4-4:2 chip ID: 0cf3:3004 serial: <filter> 

  Local Storage: total: 111.79 GiB used: 7.78 GiB (7.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Kingston model: SV300S37A120G size: 111.79 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: BBF0 scheme: MBR 

  ID-1: / raw size: 104.49 GiB size: 102.35 GiB (97.95%) used: 7.78 GiB (7.6%) 
  fs: ext4 dev: /dev/sda1 

  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 7.29 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda2 

  System Temperatures: cpu: 58.1 C mobo: N/A gpu: radeon temp: 58 C 
  Fan Speeds (RPM): N/A 

  Processes: 147 Uptime: 1h 58m Memory: 3.32 GiB used: 1.22 GiB (36.9%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1190 lib: 343 
  flatpak: 0 Shell: Bash v: 5.0.18 running in: yakuake inxi: 3.1.05 

Also I have tried using Synaptics but installing it causes my touchpad and keyboard to stop working at the next reboot.

I would try some older kernels, such as 4.14 or 4.19. Install them via Manjaro Settings Manager and boot via Advanced Options from grub’s boot menu.

Installing and booting into older LTS kernels did not solve the problem. I’ll try downloading a really old Ubuntu live CD and see what happens.

I tried booting into the Ubuntu 9.10 live CD which runs Synaptics. The cursor works normally, as it does in Windows. So, it is certainly something to do with Libinput.