Cursor colour is too dark on KDE


I’ve been really bugged by this issue, but I have not managed to find any way to solve it yet, nothing anywhere on the internet either (well, no answers).

Anyway, my cursors are all showing up too dark when I try to use them. The preview showed by KDE Settings has the right colour, but even when I hover over that, I get the darkened colour.

This image shows this. I have had to take the picture with my phone because taking a system screenshot shows the expected colour, weirdly.

I’m using KDE with Xorg, although Wayland does not fix the issue.

Does anyone have any idea what I might be able to do to sort this out?

1 Like

Try creating a new user account.
I never saw anything like this - my previews match the cursor exactly…

I gave that a go, but the cursor issue prevailed. It might be worth noting I also get this issue in SDDM. It also impacts any cursor I use, not just the Breeze ones.

Also, if it helps here is my output for inxi -F:

  Host: humboldt Kernel: 5.16.14-1-MANJARO x86_64 bits: 64
    Desktop: KDE Plasma 5.24.3 Distro: Manjaro Linux
  Type: Desktop Mobo: ASRock model: B450M Steel Legend
    serial: <superuser required> UEFI: American Megatrends v: P3.60
    date: 11/03/2020
  Info: 12-core model: AMD Ryzen 9 5900X bits: 64 type: MT MCP cache:
    L2: 6 MiB
  Speed (MHz): avg: 2661 min/max: 2200/4950 cores: 1: 3598 2: 2055 3: 3602
    4: 2055 5: 2056 6: 3596 7: 4583 8: 2034 9: 2036 10: 2038 11: 2034 12: 3047
    13: 3598 14: 2056 15: 2054 16: 2056 17: 2095 18: 3597 19: 4587 20: 2033
    21: 2034 22: 2979 23: 2032 24: 2031
  Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] driver: amdgpu
    v: kernel
  Device-2: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
  Display: x11 server: X.Org v: driver: X: loaded: amdgpu,ati
    unloaded: modesetting,radeon gpu: amdgpu resolution: 2560x1440~144Hz
  OpenGL: renderer: AMD Radeon RX 6600 XT (DIMGREY_CAVEFISH DRM 3.44.0
    5.16.14-1-MANJARO LLVM 13.0.1)
    v: 4.6 Mesa 21.3.7
  Device-1: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT]
    driver: snd_hda_intel
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  Device-3: Logitech Webcam C270 type: USB driver: snd-usb-audio,uvcvideo
  Sound Server-1: ALSA v: k5.16.14-1-MANJARO running: yes
  Sound Server-2: PipeWire v: 0.3.48 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: censored
  IF-ID-1: outline-tun0 state: down mac: N/A
  IF-ID-2: virbr0 state: down mac: censored
  Local Storage: total: 1.36 TiB used: 889.38 GiB (63.7%)
  ID-1: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB
  ID-2: /dev/sdb vendor: Toshiba model: HDWD110 size: 931.51 GiB
  ID-1: / size: 457.09 GiB used: 329.04 GiB (72.0%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 299.4 MiB used: 288 KiB (0.1%) fs: vfat
    dev: /dev/sda1
  Alert: No swap data was found.
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 54.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
  Processes: 451 Uptime: 6m Memory: 31.27 GiB used: 2.93 GiB (9.4%)
  Shell: Zsh inxi: 3.3.13

I have the same issue from long time, but darker cursors aren’t a problem for me, so I leave it as it be (but I made some tests :sunglasses:). On screenshot everything is ok, new user or Wayland don’t solve this. Messing with screen settings also don’t help. I don’t have idea what may be cause, but I suspect that there can be something in mesa driver – that’s more probable after your issue, we have identical GPU.

1 Like

I do think that is the most likely cause at this point. I have opened a bug report on the Mesa GitLab, hopefully they’ll be able to shed some light on the problem.

Looks like this is an issue with several different AMD GPUs, something to do with Gamma. (wrong colors & cursor gamma vs. modesetting/Wayland on RDNA2 (#1513) · Issues · drm / amd · GitLab). It looks like there may be workarounds. I’ll update this thread if I manage to get one working.


I also have this issue on an RX 6800.

There are 2 possible fixes for this depending if you’re using Wayland or Xorg:

  • Wayland: Use the KWIN_DRM_NO_AMS=1 as described here.

  • For Xorg: Set your AMD GPU to use a software cursor as described here.

1 Like

Thank you so much!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.