Cursor become 2 when connected with drawing tablet

This is my first time asking a question on forum. I apologize if there is something wrong with language or information written here.

First of all, I was updating manjaro with package manager. Before it finish the stuff, my laptop (Lenovo) suddenly ran out of battery. I recharge in time but the screen is goes off while the engine still running. Then I turn off the laptop forcefully by hitting that turn shutdown key button. After that, I rebooted the laptop only to face another problem with the desktop. I redirected to tty1 terminal screen instead of the desktop screen. Then I found that the problem was my gnome’s display manager is missing, so I fixed it. I thought everything is was fully recovered cuz now I can going inside the desktop peacefully, but after I connect my drawing tablet, somehow my cursor become two. It’s receives input from my touchpad and pen tablet when I move the pen.

What can I do?
I thought there is something to do with graphic card for rendering or maybe with gnome display manager.

If there any specific information needed to this, I will provide it as best as I can.

It’s not really affect my laptop performance but its really annoying to see that extra inactive cursor when I’m using my pen tablet to navigate.

I tried to do some research and I think I found the solution. After checking my tablet connection with xsetwacom --list devices I got Wayland devices found but this tool is incompatible with Wayland text. Then I do research about Wayland and try searching for answer. Voila, I found a solution to this problem.

I just edit /etc/gdm/custom.conf by uncommenting WaylandEnable=false line.

I found that solution here

After that my cursor doesn’t become 2 when I used my pen tablet

Here is what I do to solve this :

  • Found Information about Qt5 configuration and drawing tablet device
  • Found information about Gnome Gsettings
  • Found information about Xorg
  • Try xsetwacom command
  • Found information about Wayland
  • Thinking about to remove Wayland
  • Solved

I’m worrying this is not the best way to solve this problem because I didn’t know is it good to disable the Wayland.

You can log in with GnomeX11 without editing files, and in that session the cursor is fine, not duplicated and you will be able to use the xsetwacom commands … wayland can’t be removed as is required by gtk3.