Current window minimize by shortcut

Hi. How can I make my window minimze by shortcut like alt f4 works for closing, I can’t find anything about it. KDE plasma.

You mean like Meta+PgDown to minimize and Meta+PgUp to maximize?
I thought those were default.

minimized

Just right click on the bar to see the shortcuts

problem is that I have problems with my meta key, so I want customize this shortcut

I can only suppose that you have some kind of Microsoft fever - you know, the one that says that everything must be very difficult and not at all intuitive.

However, this is Linux…

Hit the menu and type ‘shortcuts’. You’ll see one choice with a keyboard.
when you open that, you see the settings app - windows are managed by ‘kwin’ so you should select that (listed under ‘system services’) and you’ll see all the options - including many that don’t even have shortcuts.

some of my favourites are;
maximise vertically, maximise horizontally, minimise, move, shade, quick tile,

It’s quite easy to map these to different kinds of keyboard shortcuts as well as mouse gestures…

basically, hitting meta with arrows is good for moving windows.
meta + up/left/right for half screen, meta + (up+right) etc for quarter screen, and so on.

If you search ‘min’ in the settings window, it brings up ‘Meta + Pgdown’ which I mapped to ‘meta+alt+Down’ to minimise windows.
These shortcuts work on all windows, but as you can see in SLalter’s post, assigned shortcuts should also appear in the menu from a right click on a kde window header. For any item with no assigned shortcut, then open shortcuts and make one!

ROFL - if you have problems with a meta key, then you must buy a new keyboard.

Take a look at installing easystroke - use gestures as well as keyboard shortcuts (more choice than you can shake a stick at).

You can hit ALT and SPACE to pull up krunner, access shortcuts from there.

Goto System-settings>shortcuts>kwin>

hello, where can I find those system services? I cant see it anywhere, also doesnt pop up in the search. But i seem to have installed kwindowsystem.
In the shortcuts there is only an option for maximizing the window right now…

I don’t understand which ‘system services’ you are asking about.
I call up Krunner with ALT+Space, type ‘sett’ to get ‘System Settings’ to show up, hit an arrow and launch it.

Open the menu or krunner and type ‘shor’ to get links to ‘shortcuts’.

sorry, I thought this is somehow a necessary step because you said [quote=“Ben, post:4, topic:42062”]
windows are managed by ‘kwin’ so you should select that (listed under ‘system services’) and you’ll see all the options
[/quote]
I now also installed krunner, but there is still no kwin or the minimise shortcut to be found.
Im not under kde plasma though, maybe that is the reason? I have the gnome manjaro

Oh dear.

Vital information - you’re using Gnome and getting ideas about KDE, because you’re posting under KDE and KDE Plasma support.

Installing Krunner wasn’t a great idea, you pulled in a ton of dependencies - my advice is to roll back (do a timeshift restore) and ask again in Gnome.

1 Like

oh damn, sorry, I didnt know how fundamental the differences were…
My system is only two weeks old (yet I put some work in it) so I didnt do any backups yet. Is there anther okayish way to get rid ok krunner for me? hmm
sorry for my noobism haha

Timeshift shouild be set up on the day you install to get a fresh start. It’s literally the very first thing to hook up on a fresh install.

Now I’d recommend doing Timeshift NOW, then think about doing a fresh install and manually copy back any stuff from the Timeshift backups you might want to keep.

1 Like

Left Shift + Left Alt + PgDown(PgDn)

minimizes the active window for me