Curl and wget able to connect to my friend's webdavs server.. but dolphin can't. it just keeps waiting for ages

this is how i typed on the address bar of dolphin:

sometime it will also display “contacted server… examing …” or similar… then stuck for ages without changes.

Where did dolphin remember the webdavs connected that op has entered ?
May be because there is no password entered… when initially i tried it… i think maybe i clicked something “not to ask for pwd” or sort of… not sure if this is the reason or not.
I have other webdavs connection in dolphin which has always being working for me… only this webdavs new server i can’t connect… however i can connect and download file using curl and wget. that shows the fault lies with dolphin.
there is something wrong with dolphin upon webdavs connection, some remote connection works, while other just “loading”. (i have 3 identical webdavs servers in different geolocation which i can choose whichever i want to login to download files)… that’s why i know it is dolphin connection issue. But since it does not show any status…

How kde plasma user download files fr webdavs server ? do they use dolphin too ? i meant if i was not given an ssh account to the server.

Not all available functionality has been added to a Manjaro ISO. For a lot of use cases you will have to configure your system to use the desired service e.g. samba, nfs and in this case webdav.

Please consult the Arch wiki as this is the autoritative documentation for various services.

To have webdav working you will likely need to build a custom package.

Probably… I think it is saved in “Kwallet”.

Thanks for hinting me.

~ /.local/share/kwalletd/ls
kdewallet_attributes.json  kdewallet.kwl  kdewallet.salt

among 3 files i got here, 2 files are sprouts language which not readable, the json file content does not show it recorded any webdavs connection.


cat *.json        
    "$fdo_created": "1663484175",
    "$fdo_modified": "1685402185",
    "LibVLC password for smb://": {
        "$fdo_created": "1664888219",
        "$fdo_mime_type": "text/plain",
        "$fdo_modified": "1664888219",
        "attributes": {
            ".created_by": "libVLC",
            "path": "/NTC",
            "port": "445",
            "protocol": "smb",
            "server": "",
            "user": "homegroupUser2"
    "LibVLC password for smb://": {
        "$fdo_created": "1668493349",
        "$fdo_mime_type": "text/plain",
        "$fdo_modified": "1668493349",
        "attributes": {
            ".created_by": "libVLC",
            "path": "/NTC",
            "port": "445",
            "protocol": "smb",
            "server": "",
            "user": "homegroupUser2"
    "LibVLC password for smb://": {
        "$fdo_created": "1677138835",
        "$fdo_mime_type": "text/plain",

it has got nothing to do with webdavs.

By the way, you type in the path, but isn’t there a wizard like that?

Just saying… (and no sorry, I don’t use KDE or Dolphin, I just try to point you to a better direction.)

i have webdavs connection already running for several webdavs remote server… even though i also don’t really understand how everything goes about, there isn’t much doc on it for dolphin. it is like if it works then it works… if not then better luck sort of thing.
asked gpt also useless, all wrong answers.

i have tried that $knetattach cmd to setup the webdavs connection, after directly type the
webdavs::// into dolphin address bar not connecting…
it also yield similar result:
something like 'loading folder" & examining the server (something like that). it just stay there for ages.


Since other webdav connections work, as you said, I would say the webserver runs a webdav implementation which is too old or not compatible. If it stuck somewhere, then I assume there is a problem with the communications. The server or the client expect a specific request or answer. That is not the first time seeing that an ancient server is not compatible with the newest client. There are sometimes breaking changes and the server has to be updated.

I wonder if it works, when you try to connect with kubuntu to the webdav server? I highly think so.

1 Like

My apology for not fully understanding your topic.

When facts are buried into layers of surrounding information - I sometime overlook them.

Is an extension of the http protocol which makes simple put, get, post, delete requests to the webserver.

why kubuntu ? u mean debian based is more stable in term of comm with server (most likely the server is also debian). However, i highly believe it is dolphin issue. because i have used this dolphin to comm with webdavs for a few years… i have seeing all type of problem with it. some time it just work, the other time it just stay there… however when i use firefox directly go to the webdavs server, it just work. dolphin just don’t… you see, from here i can sure that dolphin webdavs extension has got issue.

No prob.
I know what webdavs is… i read about it just a few days ago… … lol via gpt and bing ai… the explanation is sometime acceptable… lol.

What bothers me is that why nobody seems to voice out such issue (dolphin webdavs connection) ? is it because nobody use it this way ? Then i would really love to know how linux user download files from webdavs file server ? i am really really curious… a friend of mine who do server stuff told me he always uses ssh… but i don’t have ssh acc on the particular webdavs server… what can i do …

Also, there is nothing to debug with… no status report … no verbose output… it is so unlike linux package.

Then feel free to report it to the devs: Components for kio

kio is the backend application which manages webdav mounts.

I believe you, but Firefox just handle it as a normal website. It is different and it has its own module.

All my webdav connections work. But I use pcmanfm/nautilus/thunar with gvfs and not kio with dolphin.


Oh i see… what a relief… i thought i am the only nobody linux newbie who uses webdavs in dolphin this manner… lol… i thought they all use it like in terminal or something. lol… what a relief! thanks.

So, gvfs is also a backend app but not for kde that’s all right ? what is the one that manage for kde called ? kio is a general name for kde input/output…i think… what is the webdavs or which webdavs backend app that i am using ? I can’t remembered. because i have had this issue for months… always don’t know what to do… it works sometime when i created a new remote connection, so when it works, i just keep using it… hence no more further pursue about it. until now,it refuses to connect to the new webdavs server…

Btw, chatgpt is of not that much help regarding these… always b.s around in circle…


kio is correct. it uses kio slaves, Have look here: or more on the internet…

Well, assuming it is a bug, it has to be reproducible. Does it only appear with that specific server, or all connections? Please be more specific. Anyway, if that is a problem in kio and the devs can reproduce it, it can be fixed, but without informing them nothing will happen. Most folks don’t have any problems anyway with webdav.

I dont’ know how to reproduce it… it just happens… and not only 1 time already… in fact many times over many different connections (i highly doubt it has todo with server, because those servers that i was/ am/ would like to connect are almost identical [for load sharing purposes], just at different geolocation)… but this time is worst… no matter how i delete the connection and recreate the connection to the same server… it just like that… Previously, i can delete and redo the connection, it will be ok .

Take a look here, if you want to get more information: