Cupsd service does not start

Just made an unstable cinnamon iso.
Printing is broken no cupsd.service.
looking in /etc/systemd/system/ there are no printer items
According to systemd it needs cupsd.service, org.cups.cupsd.path and org.cups.cupsd.socket.
Should these be short cuts?
Why are they missing?

Did you read the update massage in your pacman.log? If not do it. The systemd service files for cups were renamed. You need to reenable the service if you want cups to autostart. Check the pacman.log for more information.

1 Like

I can’t it was a new install.
Changed all names to new names and re setup the service.
But why wss nothing put in /etc/systemd/system is it manjaro tools or calamares?

See:

https://forum.manjaro.org/t/cups-service-name/38888/3

Just made a new iso with manjaro-tools git, after installation no cups service.
This is perhaps due to the cups name changes but why /etc/systemd/system/ had no print files?
Is this manjaro-tools or Calamares?

I am was not aware that the cups service should have changed.

In any case the service is defined in your profile.conf and as such not related to neither Calamares nor the tools.

The service name is - and has been for years - org.cups.cupsd

I have just checked - running

$ systemctl list-unit-files | grep cups
cups.path                                  disabled        disabled     
cups-browsed.service                       disabled        disabled     
cups-lpd@.service                          static          -            
cups.service                               disabled        disabled     
cups-lpd.socket                            disabled        disabled     
cups.socket                                disabled        disabled  

And by all means - it appears you are correct - the service name has changed …

This indicates we need to amend our iso-profiles

@Manjaro-Team

https://wiki.archlinux.org/index.php/CUPS

1 Like

I’m not sure that will work, I found “systemctl enable --now cups” insisted “path” and “socket” to be
org.cups.cupsd.path and org.cups.cupsd.socket respectively.

https://bbs.archlinux.org/viewtopic.php?id=260970

sudo systemctl enable cups.service
sudo systemctl start cups.service

From Log:
Cups systemd socket and service files have been

renamed by upstream decision. Please make sure
to disable/reenable the services to your need.
hint: “pacman -Ql cups | grep systemd” and
"ls -lR /etc/systemd/ | grep cups

3 Likes

Or you can just enable the socket and the service will be started on demand: CUPS - ArchWiki

1 Like

cups-lpd@.service systemd says …
The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled using systemctl.

I think you rather want to enable the socket(s?)

cups-lpd.socket
cups.socket   

This does not answer my question:

$ systemctl list-unit-files | grep cups
org.cups.cupsd.path enabled disabled
cups-browsed.service disabled disabled
org.cups.cups-lpd@.service static -
org.cups.cupsd.service enabled disabled
org.cups.cups-lpd.socket disabled disabled
org.cups.cupsd.socket enabled disabled

Will there be an update to change to new service

Both can be enabled but only the second one works after a reboot.

You will have to manually enable/reenable the service as already pointed out by @jrichard326

➜  ~ systemctl enable --now cups          
Created symlink /etc/systemd/system/printer.target.wants/cups.service → /usr/lib/systemd/system/cups.service.
Created symlink /etc/systemd/system/sockets.target.wants/cups.socket → /usr/lib/systemd/system/cups.socket.
Created symlink /etc/systemd/system/multi-user.target.wants/cups.path → /usr/lib/systemd/system/cups.path.
1 Like

I’m confused then. Mine still works the old way.
My “/etc/system/system” still show.
/usr/lib/systemd/system/org.cups.cupsd.service

Will that change at some point? The original poster says his is blank. Is that because of the new unstable install he did?

Then your system has not received the new package. You will have to keep an eye on your updates - or you can just wait until your printer fails - then you know why :slight_smile:

➜  ~ pacman-mirrors         
Pacman-mirrors version 4.16.4
Local mirror status for unstable branch
Mirror #1   OK  00:05   Denmark  https://www.uex.dk/public/manjaro/

Thanks.
I found out that an update is coming from reading an Arch comment:
https://bbs.archlinux.org/viewtopic.php?id=260970

That comment also refers to the Arch Wiki CUPS:
https://wiki.archlinux.org/index.php/CUPS#Socket_activation
that has apparently been changed to reflect the correct service.

If using manjaro-tools simply change the cups entry in “profile-conf” in the “Enable Systemd” section from “org.cups.cupsd” to “cups”.

That’s what I told you - controlled by the profile.