Cups server error server-error-internal-error

I have a Brother MFC-J470DW that has worked on this computer for years, however the computer wasnt updated (pacman) for a good year. The printer no longer working just on this one computer. When i try to print a test page i get “cups server error” server-error-internal-error

I managed to get pacman updates done. Ive tried to reinstall cups as well. Not sure what to try next. Ive tried every type of printer setup i can think of. Usually i set them up by IP

Did you rebuild the package ? Maybe delete the printer from cups and then re-add it after rebuilding the package for it.

Im not sure how to rebuild it. I will try that next.

Im still working on the rebuild. I ran the gui printer settings troubleshooter and it enabled debugging and gathered this.

Page 1 (<troubleshoot.SchedulerNotRunning.SchedulerNotRunning object at 0x7f6211766cb0>):

{'cups_connection_failure': False}

Page 2 (<troubleshoot.CheckLocalServerPublishing.CheckLocalServerPublishing object at 0x7f6211767040>):

{'local_server_exporting_printers': False}

Page 3 (<troubleshoot.ChoosePrinter.ChoosePrinter object at 0x7f62117672b0>):

{'cups_dest': <cups.Dest Brother_MFC_J470DW>,

'cups_instance': None,

'cups_queue': 'Brother_MFC_J470DW',

'cups_queue_listed': True}

Page 4 (<troubleshoot.CheckPrinterSanity.CheckPrinterSanity object at 0x7f6211767a30>):

{'is_cups_class': True}

Page 5 (<troubleshoot.LocalOrRemote.LocalOrRemote object at 0x7f6211767f40>):

{'printer_is_remote': False}

Page 6 (<troubleshoot.ErrorLogCheckpoint.ErrorLogCheckpoint object at 0x7f62117346d0>):

{'cups_server_settings': {'BrowseLocalProtocols': 'dnssd',

'DefaultAuthType': 'Basic',

'ErrorPolicy': 'stop-printer',

'IdleExitTimeout': '60',

'JobPrivateAccess': 'default',

'JobPrivateValues': 'default',

'MaxLogSize': '0',

'SubscriptionPrivateAccess': 'default',

'SubscriptionPrivateValues': 'default',

'WebInterface': 'Yes',

'_debug_logging': '0',

'_remote_admin': '0',

'_remote_any': '0',

'_share_printers': '0',

'_user_cancel_any': '0'},

'error_log_checkpoint': 9390,

'error_log_cursor': 's=e52b94c4822d4b5984d87076c8cd9336;i=1fc00;b=afd9e80141494b2e9ca7afff91f43cde;m=16a5765209;t=5e60258a629a8;x=c653dd3b90657185',

'error_log_debug_logging_set': True,

'error_log_timestamp': '2022-08-11 21:50:38'}

Page 7 (<troubleshoot.PrintTestPage.PrintTestPage object at 0x7f621175a2c0>):

{'test_page_attempted': '11/Aug/2022:21:50:41 -0500',

'test_page_job_status': [],

'test_page_submit_failure': (1030, 'client-error-not-found'),

'test_page_successful': False}

Page 8 (<troubleshoot.ErrorLogFetch.ErrorLogFetch object at 0x7f621175a830>):

{'error_log_debug_logging_unset': True, 'journal': []}

Page 9 (<troubleshoot.Locale.Locale object at 0x7f621172d120>):

{'printer_page_size': None,

'system_locale_lang': 'en_US',

'user_locale_ctype': 'en_US',

'user_locale_messages': 'en_US'}

Well it just decided to work after removing and re adding the printer for the 15th time.