CTRL+F not working in browsers (Firefox, Chromium, Brave)

CTRL+F not working in browsers (Firefox, Chromium, Brave) to search inside web page.
Searched from KDE Settings - CTRL+F was used kind of editing in typical menu command - turned off, applied. Still CTRL+F doesn’t work in browsers. How to fix it?
OS installed recently, not configured basically - using default settings.
OS: Manjaro
DE: KDE
All updates done.
Besides: also in Pamac GUI doesn’t work the CTRL+F

Hi,

Check your system settings

2 Likes

Although I have CTRL+F for search now (had to set, wasn’t initially), it still doesn’t work, even I relogged in. Instead of that discovered, that F3 is working in browsers to find next string. So, if to enter something and search, there is no way to change the search string unless I click with mouse in menu to open search manually and delete the string, then I can enter new one (Firefox). Quite useless. Still basically need manually choose with mouse from menu and shortcut key doesn’t work, even defined via KDE System Settings as your screenshot also shows. In Chromium, Brave F3 works better, I can also change search string. But all this doesn’t get CTRL+F working in real life…

In Pamac GUI still even F3 doesn’t work but luckily I can just start typing and it will start searching.

Then you must have changed something - either way, if you can’t easily troubleshoot there are a couple of ways to do it.

  1. Lazy - restore last snapshot or the one before
  2. Hard - but sure - rename ~/.conf-BAK and reboot, copy stuff back until it goes wrong again.
  3. Harder but less hassle - targeted renaming of some of your suspect .config files/folders
  4. Copy back old versions from last week when you identify which one is dodgy.

This, of course, assumes that you have taken snapshots using Timeshift or something…

KDE is great, but it does require frequent snapshotting. Ctrl_F certainly WAS set for ‘find’ initially - something got changed by you, maybe you set it as a ‘find’ in some other app - we can’t guess if you can’t.

As an acid test, create a new user ‘TEST’, log it in and see how that works - should be default which points to some error in your settings files in /home.

To check settings, search for ‘find’

This is wired. I have install Plasma KDE on Arch, Manjaro, Debian. The shortcut of “Ctrl+F5” always work in Firefox. What version of os and firefox do you use?

Here is Firefox doc about shortcuts

Thank you all for kind suggestions! Finally I figured out, what was the issue. I’m using KDE and wanted to have dynamic zoom with certain key + mouse scroll, which was achieved via xbindkeys in KDE, because KDE directly does not support it (hopefully yet), besides - such dynamic zoom support with configurable keys via GUI exist already in XFCE via ALT-key (hold ALT and scroll mouse wheel, in some distros it is needed to turn on in first place under Assistive Technologies, there is also graphically possible to define the key, that is used with mouse scroll).

Then I discovered from ~/.xbindkeysrc that there were created example content and some of these examples were commented in and there I found binding of CTRL+F with another app, xterm in my case.

Solution:

  • commented these lines out:
# set directly keycode (here control + f with my keyboard)
#"xterm"
#  c:41 + m:0x4

# specify a mouse button
#"xterm"
#  control + b:2
  • then after saving that configuration file, restarted xbindkeys
    killall xbindkeys && xbindkeys&

After that CTRL+F was working again as expected.

To respond the previous question - using the latest software available (updating frequently), including Firefox.

2 Likes

This doesn’t address your problem but the default keyboard shortcut for searching in webpages (if you’re outside a text box) in Firefox is simply / (similar to search shortcuts in vim and other terminal applications)

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.