CSGO Freezing with Nvidia prime-run

Greetings All,

I recently fired up CSGO and noticed that it freezes everytime on both the dashboard screen and in game. I can only get in game if I quickly select everything and start a match.
I can’t force quit or shutdown properly. I have to hard restart with the power button.

My workaround for the time being is to use the Intel video driver (removing prime-run from the game properties).
Any help on this would be appreciated.


  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Notebook product: P95_96_97Ex,Rx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Notebook model: P95_96_97Ex,Rx serial: <superuser required>
    UEFI: INSYDE v: 1.07.09LS1 date: 06/13/2019
  ID-1: BAT0 charge: 57.3 Wh (100.0%) condition: 57.3/56.2 Wh (101.9%)
    volts: 16.8 min: 15.2 model: Notebook BAT type: Li-ion serial: <filter>
    status: full
  Info: 6-core model: Intel Core i7-9750H bits: 64 type: MT MCP smt: enabled
    arch: Coffee Lake level: v3 rev: A cache: L1: 384 KiB L2: 1.5 MiB
    L3: 12 MiB
  Speed (MHz): avg: 894 high: 900 min/max: 800/4500 cores: 1: 900 2: 900
    3: 900 4: 900 5: 899 6: 855 7: 900 8: 900 9: 880 10: 900 11: 900 12: 900
    bogomips: 62431
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: CLEVO/KAPOK
    driver: i915 v: kernel arch: Gen-9.5 ports: active: eDP-1 empty: none
    bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: CLEVO/KAPOK
    driver: nvidia v: 515.65.01 arch: Turing pcie: speed: 2.5 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1f11 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,nv,vesa
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x07b6 res: 1920x1080 hz: 144
    dpi: 128 size: 382x215mm (15.04x8.46") diag: 438mm (17.3") modes: 1920x1080
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa
    22.1.6 direct render: Yes

1 Like

I’ve tried uninstalling Steam and re-installing with no success. Any Steam game freezes at the menu. As I mentioned before, using the Intel driver presents no problems. Could it be a problem with the Nvidia driver alone, or perhaps a kernel module?

Any help is appreciated.


I’m having the exact same issue. No problems while running on iGPU, but when I use prime-run %command% the game randomly freezes…

Ok, I switched the linux kernel from 5.15.60-1 to 5.10.136-1 and the issue SEEMS to have disappeared. Need more time to test it, but I have been running CSGO for an hour without freezing.

Will keep you updated if something changes!

1 Like

Awesome. I was about to test an older kernel too. I think the latest kernel must be the culprit. I’m going to bring this issue to the right folks who might be able to patch this in the next kernel update. I’ll report back if I get the same result using 5.10.


1 Like

Switching to an older kernel seems to do the trick, for the moment (5.10.136-1). I was on for well over an hour, several times throughout the day and no freezing in sight. It must be the newest kernel that doesn’t play well with Nvidia on some laptops. At least a temporary workaround is possible.



This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.