Creating KVM/Qemu bridged nic


I have tried to create a bridged nic with nmcli following this guide:

My need is to allow linux/windows vms to get physical network up address through router dhcp.
Nic is created but it does not work.
Any hint/recommendation on how to solve this problem?


I had the same issue with my VM. When you enslave main device to bridge connection and set it on virutal NIC you could reach (ping etc.) guest but not host. To reach guest and a host you could do it in easy way:

  • Open your DE network manager,
  • disconnect from your main internet connection and disable auto connect option,
  • create new virtual connection - bridge,
  • disable stp and add bridged connection - Ethernet type and tie it with your network card in device section, next check in General options: All user could connect to this network and automatically connect,
  • save all changes and reboot system,
  • double check if you are connected to ethernet - bridged connection,
  • open terminal and use command: ip a to check the correct name of the bridge connection You just created,
  • change in virt-manager NIC option from NAT to bridge and enter the connection name from previous step,
  • save changes and run the VM to test settings.

If everything is set up correctly host should get IP: (e.g.) 192.168.1.X; guest: 192.168.1.X + 1; router: (no change).

Thanks @Dwuimienny for your reply.
I haven’t use this for months but now I got a new hardware and I am facing a similar problem.
I have done the steps you suggest but it is the last that fails. From inside the VM I can’t make the NIC working.
The following is my host configuration:

After I created the bridged connection it also created vnet6 of type ‘tun’, I am not sure what is the reason?