Creality Slicer AppImage not loading - QT network SSL errors

Hi all,

I have asked the question already to the developers, but did not get an answer. So maybe someone here have an idea.

I am trying to launch an applicaton named “Creality Slicer”. That is a piece of software to create files to be printed on a 3D printer.

Creality is the manufacturer, they offered a most recent Appimage for Linux.
But everytime when i am trying to launch it i am getting this error: QSslSocket: cannot resolve EVP_PKEY_base_id QSslSocket: cannot resolve SSL_get_peer_certificate
Speicherzugriffsfehler (Speicherabzug geschrieben)

(The last sentence in German says “Memory access error”)
I have no clue if this can be solved by myself or if the app developer need to do it.

I have also tried it on other distributions (Debian, Fedora, both with KDE) and the error remain the same.

If someone has an idea, would be great.

The issue is due the fact that the appimage might not contain the ssl libraries. The default openssl that is version 3 has dropped some particular x509 functions. Do you have openssl-1.1 package installed? If not, install it and try your appimage again.

No, i did not. But i added it now.
And what should i say: it fixed the issue, the app is working!

Many thanks for your super fast response.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.