Crashed after recent update

Hi I just updated my manjaro and it crashed after update, no terminal or graphic shows only with the following shows on the screen

it seems that the nvidia drive was replaced…

I have lots of things saved in that system and really need it…

Anyone help pls, thanks!!

1 Like

hi i tried and got an error msg after startx

which says no screen found

One thing I notice is your kernel is EOL.
Since you can get to runlevel 3 or similar…
Then you will want to first boot into a different kernel.
If you dont have one installed…

sudo mhwd-kernel -i linux61

Then reboot

systemctl reboot

Grub should allow you to select kernel at boot - if you dont see it then try hitting Esc
You can check current running kernel with … uname -r
Then proceed to remove the EOL kernel …

sudo mhwd-kernel -r linux62

And do updates for good measure:

sudo pacman -Syu

Then reboot and check

1 Like

seems not work, reverted to linux61 and still no graphic.

my graphic card is gtx1650, the current info says it does not have a driver

the pacman -Syyu doesn’t up grade…

To reinstall the driver you could

sudo mhwd -f -i pci video-nvidia
1 Like

Non-standard repositories may complicate matters. I don’t think that it is necessarily the cause of the current problem, but…

it seems like the one of the pkg (maybe psensor) blocked the upgrade of nvidia driver

You could

  1. verify that no other package depends on psensor
  2. delete psensor
  3. reinstall the driver
  4. reinstall psensor

i did, psensor need libxvnctrl, which actually blocked the reinstall of nvidia

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.