Crackling sound at boot/shutdown


I’m very happy using Manjaro, thanks for providing it! The only problem I have is that my speakers produce crackling sound (very loud pop) at each shutdown and boot (before the login screen), while the sound at boot is much louder. It’s bad for my speakers so I really need to fix this.

I suspect it happens at alsa or pulse audio start, but it does not happen if I restart pulse audio later in konsole with systemctl --user restart pulseaudio

Devices: NVIDIA, Advanced Micro Devices [AMD] Family 17h HD Audio
The driver is: snd_hda_intel (for both devices)
Power save and power save controller are already disabled. The speakers are connected to the headphones jack, to the AMD Family 17h audio - I don’t have any other output (speakers) jack.

BTW: there is no such problem in Windows.

Thanks in advance for your help!

That’s typical: Windows drivers are programmed to work around bugs in the hardware. You have a hardware problem, so:

  • Sometimes upgrading the BIOS/UEFI firmware can solve this.
  • If no newer firmware available: turn down the volume on your speakers to 0 before shutting down and turn it back up after booting.


Thanks for your help. It’s a brand new laptop, Bios & EC are already at the newest version, so I cannot do anything in this respect.

I already had such problem with my previous laptop (HP 8730W) and the same speakers (Harman Kardon SoundSticks) on Kubuntu Linux. I solved the problem switching from the docking station’s jack to the headphones on the laptop. I have no alternative jack any more.

I’m sure there must be some workaround - how could I turn off/mute the speakers programmatically at the boot? They are unfortunately very clumsy to turn off, the button is only on the subwoofer below my desk and the volume increase buttons are only +/-, no quick rotation and no indicator, very clumsy, I know - but the sound is great.

I would really appreciate some help, I’m sure it’s just a matter of a workaround in the Manjaro’s config files.

You could always use the following command:

amixer set Master toggle off

in a customised systemd service, but I’m not convinced it will execute fast enough to get rid of the pops and cracles at the right time when booting.

At log-in you can then use autostart applications to do a:

 amixer set Master toggle on

and at logout another off.

(Like I said: that’s what I would do, but I haven’t tested it for you, just pointing you in the right direction as every PC is different… E.G Your profile does not contain your DE and neither does your question contain a DE tag.)