CPU undervolting leads to shutdown/boot loop

Hello to everyone. I am very new to Linux and I am having a complication I don’t know how to solve. For starters I have an Intel 9900KS set to 4.8ghz with a voltage of 1.22v with a Gigabyte Aorus Z390i Motherboard inside a SSUPD Meshlicious case. I moved away from water cooling and wanted to go with Air cooling but in order to keep my temps under control I had to under volt and under clock my CPU. Unfortunately in doing so I can no longer boot into Manjaro. Windows works flawlessly, but every time I try to boot into Manjaro after pressing enter on the boot loader, the entire PC will shut down about a second and half after that and will do so indefinitely until I change the VCore back to AUTO.

Is there something by chance that Manjaro or Linux in general is looking for or doesn’t like about my bios settings? I definitely want to learn Linux but this problem is keeping me from even running the OS.

I think you just have a poorly configured motherboard, the fact Windows loads is not indicative that you did a good job.

1 Like


So well… my guess is that of you undervolt the cpu by bios, then it will stick to specific frequency and don’t up and downscale as needed. So if this is the case then the module acpi_cpufreq is here the problem. You will need to blacklist this module.

At BIOS level you set it to a specific frequency and when acpi_cpufreq try to up and downscale the frequency, it crashes.

At least that is my guess.

Hum that could make sense actually.

Care to help walk me through what to do?

Please read this: https://wiki.archlinux.org/title/Kernel_module#Blacklisting

Simply blacklist acpi_cpufreq then.

If you have questions, then just ask.

Thank you so much I will give it a try and report back tomorrow :slight_smile:

Not to derail, but are you using your computer in the middle of the Sahara Desert? Unless you got unlucky with a faulty CPU from a bad batch or wafer, there’s no reason it must be under-volted and under-clocked in order to stay within designed temperatures.

Either that, or you did not properly install the heatsink and/or thermal paste. It can absolutely make a difference of 10C degrees (sometimes more) depending on how you apply the paste, what paste you use, and how evenly you pressure the bottom of the heatsink. (Do not use the thermal pads. While they may be “cleaner”, easier to apply, and re-usable, they are inferior by a wide margin compared to quality thermal paste. They’re fine for NVMe / m2 drives due to the convenience of cutting them to size, but for CPUs they have poorer thermal conductivity than the pastes.)

The Intel Core i99900KS Processor 16M Cache up to 5.00 GHz Product Specifications CPU specs states:

Max Turbo Frequency: 5.00 GHz
Intel® Turbo Boost Technology 2.0 Frequency: 5.00 GHz
Processor Base Frequency: 4.00 GHz

Did you under clock the Max Turbo frequency for a single core work load mode?

Much more stable way is to turn off turbo boost (or lower it’s max GHz limit if it is configurable) instead of any experimenting of CPU voltage changes.

CPU can’t heat up that much to leave throttle phase behind and to go into CPU shut down during a couple of seconds run of Linux kernel load, while whole Windows boot up and usage is not.
It should be not a CPU temp issue, it is most probably a software-originated issue.

Is it unable to check journalctl logs of such boot ups?

When I am only using a Noctua NH-L12s it will. I would thermal throttle just installing shaders on a game.

All core is 4.8. When I have had it booted in Linux and checked the system stats it was only running at 4.0 all the time.


Just a side note: Wouldn’t it be better to restrict frequencies to prevent heating up the cpu?

For example cpupower can be run as a service, which will enable automatically you frequency settings on boot. https://wiki.archlinux.org/title/CPU_frequency_scaling#cpupower

And there is also a gui: cpupower-gui


As always: if stability suffers one has achieved nothing.

If heat is a problem when the cpu is running at specs perhaps the machine needs a dust-off?

Why do you keep talking about a CPU temp? Does Linux kernel can load a CPU up to it’s self-shutdown temp in a couple of seconds, while Windows boot up process and usage can’t?
Also what is the possibility that a machine dust affects only Linux kernel, but not Windows one?

He’s using “inappropriate” cooler for his CPU (officially should work though to stay under 99°C in stress). Also he may have a bad mount (probably the case if he has problem with temperature and requires underclocking/undervolting).

I still think it is a matter of properly configuring the motherboard.

1 Like

I still believe the issue of temperatures needs to be addressed, without resorting to under-volting or under-clocking.

  • Thermal paste may need to be cleaned and re-applied properly.
  • Heatsink may need to be re-seated.
  • Airflow may need to be optimized and/or dust cleaned from the fins, blades, etc.

@Fuss what temps were you getting on idle / load before under-volting and under-clocking?

1 Like

I didn’t know I was able to do this in the OS

Thermal paste, reseating and airflow was never the issue it’s too small of a cooler for this CPU but it’s what fits in my case. idle temps are fine but in game cpu temps were hitting TJMax

After going thru what things I have changed in the bios it turns out to have been a voltage/LLC issue but mostly LLC. I don’t remember changing the LLC but that’s what it was, I think it was a bit aggressive.

So your issue is solved, it was a bad underclocking/undervolting, wrong configuration of motherboard?