Cp: target '/var/tmp/mamac/dbs/sync': Not a directory; Error: Failed to prepare transaction: target not found: rttr

Hello, on Manjaro 5.15.122-1 with KDE I did “pamac upgrade -a”

cp: target ‘/var/tmp/mamac/dbs/sync’: Not a directory
Error: Failed to prepare transaction: target not found: rttr

So after checking forum, i tried: pamac remove rttr

Then i have confirmed pamac update prompt:

Edit build files: [e]
Apply transaction ? [e/y/N] y

yet it said:

Transaction cancelled.
cp: target ‘/var/tmp/pamac/dbs/sync’: Not a directory

upon repeating the pamac upgrade, it complained the same for different package: kmediaplayer
So I have removed it too and ran “sudo pacman -Syyu”. It updated some keys and asked many times replacing packages like “Replace baloo with extra/baloo5? [Y/n]” so I have cancelled it and retry “pamac upgrade -a” with same result, only now it is “perl-class-accessor-lite”.

So as suggested on the forum, I have tried to “sudo mv /var/tmp/pamac $HOME/” (was it really needed to move to user /home instead of just deleting?) and now “pamac upgrade -a” found upgrades and installed it.

I am wondering what was wrong, how to prevent it and how to do things better next time?

I think you didn’t update for a very long time.

Refresh your mirrors first: sudo pacman-mirrors --geoip
Then, do the update without AUR packages: pamac update --force-refresh --enable-downgrade --no-aur

Say “Yes” to all replacement questions.

Then, we can look what’s happening.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.