Couldn't run npm run on ntfs partition

I already posted a similar post a while ago Npm package installation error on other partition

I got a similar error occurred again:

sh: line 1: /mnt/Personal/project-name/node_modules/.bin/mix: Permission denied

I saw this:

One of the accepted answers was adding exec to the mount option, and so I did:

UUID=7ED15E311F3DF5B1 /mnt/Personal ntfs nofail,noatime,rw,exec,user,uid=1000,gid=1000,dmask=022,fmask=133,windows_names,auto 0 0

But I’m still getting the same error.

Did you reboot/remount fter the change?

/mnt is usually for temporary mounts not permanent ones, you should find another mount point.

1 Like

Yes, I did.

How about /media/Personal?

I tried changing the mount point to /srv, /home and inside it, restarted it, but nothing happened the error is still there.

I also tried changing the type to ntfs-3g. But it’s still there.

I just noticed the permission of the file that causes this problem is -rw-r--r--. I looked at my backup project and it has 755, so I tried changing it to that but it doesn’t let me. It doesn’t throw any error but the permission is still 644.

NTFS has no concept of these access rules.

oh okay, what should I do then? i already tried updating npm and node as well but it’s still there.

Also tried placing exec after user

UUID=7ED15E311F3DF5B1 /home/Personal ntfs-3g nofail,noatime,rw,user,exec,uid=1000,gid=1000,dmask=022,umask=022,fmask=133,windows_names,auto 0 0