Couldn't get a file descriptor referring to the console

Hi, this is my first post. I wasn’t sure which category I ashould put this under, so here it is since I’m using XFCE.

I was trying to change the font on my system. I downloaded a .ttf I liked, I put it in /usr/share/fonts/TTF using root privileges. I installed it with: $fc-cache -f -v
and the installation succeeded.

I wanted to setfont or even to just to check the current font with showconsolefont, but each time I get the following message:
“Couldn’t get a file descriptor referring to the console”.

Whichever additional information you need in order to name the problem, feel free to give me instructions on what I need to do.

Thank you.

Was there no interesting font to install from the repositories?

That’s not a problem. I haven’t said what I’ve installed. Do you know how to fix the given error? :slight_smile:

First search result:

I have seen that answer but it didn’t work for me. I’ve tried to overwrite from /etc/skel to home directory to make sure I didn’t have anything unnecessary.

The problem was that I have tried to change the font of a terminal emulator, but was actually changing the tty, console, font. That was the problem.