Could not open file /var/lib/pacman/local/linux-firmware-20200923.r1716.afbfb5f-1/desc:


I have manjaro kde installed on a USB 3 drive which has been working well until the last update.

First problem occurred when I tried to boot and got this after GRUB window:
error: file ‘/boot/vmlinuz-5.4-x86_64’ not found
error: you need to load the kernel first

But then selecting the kernel on the next page lead back to the message above.

Then I tried Stephane’s recommendation in another post and chrooted into my usb from another live iso. Having used pacman -Syy and pacman -Syu I used mh-kernel -i linux57 and go the following:

could not open file /var/lib/pacman/local/linux-firmware-20200923.r17

Now I’m stuck. Any help very much appreciated. Thanks!


would guess there are data corrupted… Try to repair it first:

Check which device it is…


and then repair

fsck -f -y -c /dev/sdY1

(keep sure the drive is unmounted)

Then remove the folder rm -Rf /var/lib/pacman/local/linux-firmware-20200923.r1716.afbfb5f-1/ … it will be recreated by reinstalling it.

1 Like

Was going well until the repair returned this below. I’m going to cut my losses and give M20.1 a try!

Thanks for your help though!

[manjaro@manjaro ~]$ sudo fsck -f -y -c /dev/sdb
fsck from util-linux 2.36
e2fsck 1.45.6 (20-Mar-2020)
ext2fs_open2: Bad magic number in super-block
fsck.ext2: Superblock invalid, trying backup blocks…
fsck.ext2: Bad magic number in super-block while trying to open /dev/sdb

The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem. If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193
e2fsck -b 32768

/dev/sdb contains `DOS/MBR boot sector MS-MBR Windows 7 english at offset 0x163 “Invalid partition table” at offset 0x17b “Error loading operating system” at offset 0x19a “Missing operating system”, disk signature 0x150355; partition 1 : ID=0xb, start-CHS (0x4,4,1), end-CHS (0x3ff,254,2), startsector 2048, 1048576 sectors; partition 2 : ID=0x82, start-CHS (0x3ff,254,2), end-CHS (0x3ff,254,2), startsector 1050624, 20480000 sectors; partition 3 : ID=0x83, start-CHS (0x3ff,254,2), end-CHS (0x3ff,254,2), startsector 21530624, 47104000 sectors; partition 4 : ID=0x83, start-CHS (0x3ff,254,2), end-CHS (0x3ff,254,2), startsector 68634624, 51492816 sectors’ data

You didnt specify a partition like that:

sudo fsck -f -y -c /dev/sdb1

The Partition must have a be linux filesystem :wink: