Corsair Keyboard requires replug on OS startup

I have a k70 Corsair Keyboard plugged into an ROG Strix B450-F motherboard. Most of the time, when I start my computer up, the keyboard will work fine up until the OS loads. It will light up fine, and I can choose boot or bios options perfectly fine, but as soon as it loads into the OS, I can’t type anything. I have to unplug and replug the usb’s to get it to type again. Sometimes the lighting will get messed up, but usually the lighting is fine throught this. I’ve tried every USB on the computer and nothing makes a difference. I do not have this problem with any other USB devices. I usually use CKB-next to control the software, and it works well with no issues I’ve seen. Restarting that program does not work to get the keys to work, however. I’m using Plasma and 5.10, but it didn’t work on past Kernals either.

Use the virtual keyboard after booting to:

  • Log in
  • Go to System SettingsKeyboard
  • Look at whatever is in keyboard model as in below screenshot:
  • Quit System Settings
  • Unplug Corsair
  • Plug Corsair back in

Go back to System Settings and repeat the above steps.

  • If the keyboard model changed, increase the delay with 1 ms to be able to change something on this screen and click Apply to fix it.
  • if nothing was changed, go to the Corsair Website and look which exact hardware the Corsair is emulating and choose that model… (You might get lucky and it might be on the bottom label of the keyboard too)

Next time, look at Linux compatibility before buying a keyboard because “Corsair” is not in the list of Linux compatible keyboards…


If that doesn’t work, please read this:

and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU you have, …

Thanks! Strangely it has not happened in a few days, but I will try it as soon as it does happen. And thanks for the tip

1 Like

OK, so I was able to try it out, and it seems like the model didn’t change, so I tried to find out which hardware they’re trying to emulate, but I didn’t seem to have much luck. I’m not sure I’m missing something though.

Edit: NVM, it seems to be a problem with ckb-next. Uninstalling it helped, but idk if theres anyway to allow myself to control the lighting and have it work

Here is the info as requested

  Kernel: 5.10.7-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=fb76771e-c2fb-45f6-938a-5029c1b414d0 rw quiet apparmor=1 
  security=apparmor resume=UUID=34903fdd-2ada-44e8-af4d-0b4ea0dd20fd 
  Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx 
  serial: <filter> UEFI: American Megatrends v: 3103 date: 06/17/2020 
  RAM: total: 31.35 GiB used: 2.32 GiB (7.4%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 8-Core model: AMD Ryzen 7 2700 bits: 64 type: MT MCP arch: Zen+ 
  family: 17 (23) model-id: 8 stepping: 2 microcode: 800820D L2 cache: 4 MiB 
  bogomips: 102241 
  Speed: 1378 MHz min/max: 1550/3200 MHz boost: enabled Core speeds (MHz): 
  1: 1378 2: 1427 3: 1542 4: 1471 5: 1488 6: 1482 7: 1485 8: 1539 9: 1459 
  10: 1378 11: 1379 12: 1377 13: 1379 14: 1547 15: 1479 16: 1483 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca 
  mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl 
  npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb 
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 
  rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap smca sme 
  smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce 
  topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt 
  xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: Gigabyte driver: nvidia 
  v: 460.32.03 alternate: nouveau,nvidia_drm bus ID: 08:00.0 
  chip ID: 10de:1b80 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 5120x1530 s-dpi: 107 s-size: 1216x363mm (47.9x14.3") 
  s-diag: 1269mm (50") 
  Monitor-1: DVI-D-0 res: 2560x1440 hz: 60 dpi: 109 
  size: 597x336mm (23.5x13.2") diag: 685mm (27") 
  Monitor-2: DP-4 res: 2560x1440 dpi: 109 size: 597x336mm (23.5x13.2") 
  diag: 685mm (27") 
  OpenGL: renderer: GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03 
  direct render: Yes 
  Device-1: NVIDIA GP104 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 08:00.1 chip ID: 10de:10f0 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 0a:00.3 chip ID: 1022:1457 
  Device-3: Logitech HD Webcam C615 type: USB driver: snd-usb-audio,uvcvideo 
  bus ID: 1-1:2 chip ID: 046d:082c serial: <filter> 
  Device-4: VIA FX-AUDIO-DAC-X6 type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 3-3:3 chip ID: 040d:340b 
  Sound Server: ALSA v: k5.10.7-3-MANJARO 
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel 
  port: e000 bus ID: 03:00.0 chip ID: 8086:1539 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: e000 
  bus ID: 07:00.0 chip ID: 8086:2723 
  IF: wlp7s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  IF-ID-1: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  IP v6: <filter> scope: link 
  IF-ID-2: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  IP v6: <filter> scope: link 
  WAN IP: <filter> 
  Message: No RAID data was found. 
  Local Storage: total: 4.66 TiB used: 466.34 GiB (9.8%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SUV400S37120G 
  size: 111.79 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 96R9 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital 
  model: WDS200T2B0A-00SM50 size: 1.82 TiB block size: physical: 512 B 
  logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 40WD 
  ID-3: /dev/sdc maj-min: 8:32 vendor: Toshiba model: HDWD110 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: A8J0 
  ID-4: /dev/sdd maj-min: 8:48 vendor: Seagate model: ST2000DM006-2DM164 
  size: 1.82 TiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: CC26 
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: BD-RE WH16NS40 rev: 1.02 
  dev-links: cdrom 
  Features: speed: 48 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
  ID-1: / raw size: 102.69 GiB size: 100.58 GiB (97.94%) 
  used: 89.49 GiB (89.0%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: fb76771e-c2fb-45f6-938a-5029c1b414d0 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 300 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 0438-46FB 
  ID-3: /gaming raw size: 2.73 TiB size: 2.71 TiB (99.18%) 
  used: 376.85 GiB (13.6%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0 
  mapped: vg0-bulk label: N/A uuid: N/A 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 maj-min: 8:3 label: N/A 
  uuid: 34903fdd-2ada-44e8-af4d-0b4ea0dd20fd 
  ID-1: /dev/sdb1 maj-min: 8:17 size: 579 MiB fs: ntfs label: System Reserved 
  uuid: 9E2009F92009D8E3 
  ID-2: /dev/sdb2 maj-min: 8:18 size: 1.82 TiB fs: ntfs label: N/A 
  uuid: 429C0BF89C0BE56F 
  ID-3: /dev/sdb3 maj-min: 8:19 size: 100 MiB fs: vfat label: N/A 
  uuid: AA6B-5E16 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 1-1:2 info: Logitech HD Webcam C615 type: Audio,Video 
  driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 046d:082c serial: <filter> 
  Device-2: 1-5:6 
  info: Corsair CORSAIR K70 RGB MK.2 SE Mechanical Gaming Keyboard 
  type: Keyboard,HID driver: usbfs interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  chip ID: 1b1c:1b6b serial: <filter> 
  Device-3: 1-9:4 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0029 
  Device-4: 1-10:5 info: Corsair H100i v2 type: <vendor specific> driver: N/A 
  interfaces: 1 rev: 1.1 speed: 12 Mb/s chip ID: 1b1c:0c09 serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 3-1:2 info: Logitech G502 SE HERO Gaming Mouse type: Mouse,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  chip ID: 046d:c08b serial: <filter> 
  Device-2: 3-3:3 info: VIA FX-AUDIO-DAC-X6 type: Audio,HID 
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 2.0 
  speed: 12 Mb/s chip ID: 040d:340b 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 
  System Temperatures: cpu: 38.4 C mobo: N/A gpu: nvidia temp: 48 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 21% 
  Processes: 371 Uptime: 3m wakeups: 0 Init: systemd v: 247 Compilers: 
  gcc: 10.2.0 clang: 11.0.1 Packages: pacman: 1516 lib: 446 flatpak: 0 
  Shell: Bash v: 5.1.0 running in: yakuake inxi: 3.2.02 

So: no, sorry, don’t kill the messenger, don’t buy Corsair, any more nor Acer as I have the same problem on their Predator line of laptops: I need to keep Windows around in dual boot, just to change my keyboard colours.


P.S. One last piece of advice: with 32GB of RAM, create the following file:


and copy the following into it:

# invanaar: 2021-02-09: Changed "swappiness" from default 60 to 10:
#  Theoretically, only swap when RAM usage reaches around 80 or 90 percent
vm.swappiness = 10

# invanaar: 2021-02-09: Lower vm.vfs_cache_pressure to 75%
# (once cached, probably not immediately needed any more)
# This percentage value controls the tendency of the kernel to reclaim
# the memory which is used for caching of directory and inode objects.
# At the default value of vfs_cache_pressure=100 the kernel will attempt to
# reclaim dentries and inodes at a "fair" rate with respect to pagecache and
# swapcache reclaim.  Decreasing vfs_cache_pressure causes the kernel to prefer
# to retain dentry and inode caches.
vm.vfs_cache_pressure = 75

The above is pretty self-explanatory and will become active at the next reboo.
These parameters will ensure your machine swaps later rather than sooner and once it swaps out, it will not try to swap in immediately neither, so your machine will be “snappier” while under high MEM load.

Thanks! that makes sense

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.