Corrupted package during install

Ahhh yeah that was exactly this package that messed up all my recent tries with Architect.

Before, I sometimes had the Partition too full issue seen there [SOLVED]Pacman "Partition / too full" error, despite available space / Newbie Corner / Arch Linux Forums

I tried - and succeeded - yesterday by dowloading and using old (last version 20.0.3) Architect iso, instead of launching Architect from the latest Manjaro isos (Gnome, KDE, …)

That didn’t work either …I’ll try 1 mirror at a time…brb.

Maybe your cache is corrupted:

  • pacman -Sc (cleans unused packages)
  • pacman -Scc (cleans all packages)

Could be, but I just installed yesterday after a different switch branches problem… and I’ve deleted and downloaded confuse multiple times. Maybe I should just reinstall…I’ve had a lot of practice lately

Please check pacman-key --list-keys | less and post the output of the given key. Mine looks like:

pub   rsa4096 2015-02-08 [SC] [expires: 2022-05-18]
      BFA1ECFEF1524EE4099CDE971F0CD4921ECAA030
uid           [  full  ] Baptiste Jonglez <baptiste@bitsofnetworks.org>
uid           [marginal] Baptiste Jonglez <baptiste@jonglez.org>
sub   rsa4096 2015-02-08 [E] [expires: 2022-05-18]
sub   rsa4096 2015-02-08 [S] [expires: 2022-05-18]
pub   rsa4096 2015-02-08 [SC] [expires: 2022-05-18]
      BFA1ECFEF1524EE4099CDE971F0CD4921ECAA030
uid           [marginal] Baptiste Jonglez <baptiste@bitsofnetworks.org>
uid           [ unknown] Baptiste Jonglez <baptiste@jonglez.org>
sub   rsa4096 2015-02-08 [E] [expires: 2022-05-18]
sub   rsa4096 2015-02-08 [S] [expires: 2022-05-18]

Should I nano it and change to full and marginal?

LOL…that didn’t work.

[missi gnupg]# pacman-key --list-keys | nano
Too many errors from stdin

Buffer written to nano.save
[missi gnupg]#

@SlowMotion Do you know which file has the key? I think I can look up there above

One does not simply edit the output of pacman-key… sorry, could not resist :slight_smile: It’s not editable because it’s generated from your key list. Wait a minute, I’ll check the options.

Is it possible to run pacman -S archlinux-keyring manjaro-keyring?

install? or -S? I’ll try it.

Sorry, corrected. Mixed up pacman and pamac :slight_smile:

That worked. Do I have to get rid of the ubuntu keys?

Ubuntu keys? And did it change the output of pacman-key --list-keys | less?

Edit: Ah, you mean the Ubuntu keyserver. It is part of the keyserver network and contains not only Ubuntu keys. So it doesn’t matter which server you’ll use. I just choose a stable one.

no same

Well that’s good news…to fix manjaro with ubuntu would be a little degrading…lol.

Ok, than after reinstalling the keyrings you can try again to reinitialize the key store:

cd /etc/pacman.d/gnupg
rm -r *
pacman-key --keyserver keyserver.ubuntu.com --init
pacman-key --keyserver keyserver.ubuntu.com --populate archlinux
pacman-key --keyserver keyserver.ubuntu.com --populate manjaro
pacman-key --keyserver keyserver.ubuntu.com --refresh-keys
1 Like

I’m getting a lot of “key not changed.”
I don’t think rm -r * is deleting the keys.
It ended the same.

This worked…if I do @SlowMotion’s fix and delete the last command, it works. Like this:

sudo pacman -Syyuu

Thanks for all your help @SlowMotion!! You saved the day!

You’re welcome and thanks to @helics1 for finding the missing piece!

2 Likes