Corrupted fonts in Snap Dialogs

I find that I only have issues with system dialog boxes (gnome desktop). The fonts within snap apps are fine, but if they need to open a dialog box of any kind (about box, file dialog, etc) - then it’s just rectangles.

I’ve tried all the cache removal tricks mentioned in this thread and others on the archived forum, but no impact on the dialog box problem.

Any ideas?


I am having the same problem with the Snap Instagram port app. I open a dialogue menu and it is all little rectangles. :frowning:

Me too. I’ve a fresh instalation and doesn’t work

I am not sure if this is the same issue or not. The suggested fix, which is reported to only last for a while, does not fix the errors I get, so it may be different:

sudo rm /var/cache/fontconfig/*
[sudo] password for jim:
[jim@jim-MonsterManjaro ~]$ rm ~/.cache/fontconfig/*
[jim@jim-MonsterManjaro ~]$ fc-cache -r
[jim@jim-MonsterManjaro ~]$ cloudcompare.CloudCompare       
QSocketNotifier: Can only be used with threads started with QThread
Gtk-Message: 21:14:02.771: Failed to load module "canberra-gtk-module"
Gtk-Message: 21:14:02.806: Failed to load module "colorreload-gtk-module"
Fontconfig warning: FcPattern object weight does not accept value [40 210)
Segmentation fault (core dumped)

I am trying to run CloudCompare, but cannot get past this problem.

If it is the same, please help!

Manjaro KDE (Stable)
I have tried uninstalling and reinstalling as well.

As this seems possible to replicate with a fresh install and in both KDE and gnome desktop environments I’d like to turn the question around:

Does anyone actually have working fonts in system dialogs for snap applications in a current manjaro install?

If we can establish that someone has a working setup I’m thinking perhaps we can start to run down differences between a working setup and non-working setup in order to get some clues. I’ve found nothing interesting in any logs or otherwise to give me any thread to start pulling on in order to unravel this really annoying deficiency.

My Snap fonts problem with the InstagramPort app got solved when I read I could open to the Instagram web page right click on the page and look for a tiny device icon in the far upper left corner. Click on it to see it turn blue then refresh the page. Now I could add photos to Instagram from the Manjaro desktop. Bye bye Snap.

This is a perpetual issue for me - I have no fix except opting for the AppImage, using the AUR, or doing my own build. I have Snap disabled on my laptop install. There are a few apps (one example is YouTube client, Red) which are Snap only, but the dialog box/font issue is not crucial there.

No one has replied confirming they have working system dialog fonts so far - so there’s unfortunately nothing to compare against to try to narrow it down :frowning:

Same here… Trying to use deckboard and whatsdesk… Try to remove da font caches as the Arch Wiki, but still not working…

same here. no solution yet.

I finally gave up. I hated snaps apps anyway. I uninstalled and removed all trace of snaps. Good riddance.