Correct System Time

System time time/date widget is off by two minutes compared to internet & broadcast TV,

Going to system settings, if I uncheck “set date & time automatically”, correct the time manually, “error can not set time”

I find both are the sam time, and the setting is check.

Welcome to the forum!

If your time server is off, you can always set a different one in /etc/systemd/timesyncd.conf — see the NTP= line. I have set mine to — I’m in Belgium, so depending on your locale, that may not be the correct setting for you.


Don’t forget to reload the configuration or — perhaps easiest for you — reboot after changing the setting.

1 Like

Something else to note - isn’t always reliable. Looking at this just now, jumped from 15 to 37 seconds… and a few other random jumps to boot - I have no idea why that’s even possible.

I’m on a Lenovo v-14 [amd] KDE Manjaro updated time 2 minutes behind
On a different lenovo T495 [amd], updated Manjaro KDE, same network, system time spot on

My phone [android], broadcast tv & all agree on the time that’s 2 minutes & change different than my v-14 system time, across different time zones

❯ doas hwclock --verbose                    
doas (ben@evo) password: 
hwclock from util-linux 2.38
System Time: 1658545877.616980
Trying to open: /dev/rtc0
Using the rtc interface to the clock.
Last drift adjustment done at 1658067323 seconds after 1969
Last calibration done at 1658067323 seconds after 1969
Hardware clock is on UTC time
Assuming hardware clock is kept in UTC time.
Waiting for clock tick... clock tick
Time read from Hardware Clock: 2022/07/23 03:11:18
Hw clock time : 2022/07/23 03:11:18 = 1658545878 seconds since 1969
Time since last adjustment is 478555 seconds
Calculated Hardware Clock drift is 0.000000 seconds
2022-07-23 10:11:17.718299+07:00

Thankfully I never noticed any drift.

I can find dev>rtc0
How do I open it?
I didn’t mean to mark as solved…

If you mean: “How can I open /dev/rtc0
I think, only hwclock can read /etc/rtc0 from BIOS in your mainboard.
Try to run hwclock --verbose

Did you check time in BIOS?

If you try ‘hwclock’ you’ll see options…
If you run ‘hwclock’ it will tell you it needs more super powers… so then you go back and try again with sudo.

Packages doas and hwclock are not included on Manjaro official ISOs, so IMO it would be simpler to use the installed tools to check/update clock

systemctl status systemd-timesyncd

to check if time was correctly synchronised when system booted

systemctl restart systemd-timesyncd

to restart the service; check ntp server and synchronise clock


sudo ntpd -qg

Thank you
That was fun, recounted the history & lined it right up


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.