Core dumped (Manjaro Openbox)?

I’m using a raw developer called Filmulator on 2 machines with Manjaro Openbox, both updated to the latest, and kernel 5.10 (on this pc I’m writing now, can’t check the other but it should be the same).
Filmulator stopped running, and launching it from the terminal I get this error message:

/usr/include/c++/11.1.0/bits/stl_vector.h:1045: std::vector<_Tp, _Alloc>::reference std::vector<_Tp, _Alloc>::operator[](std::vector<_Tp, _Alloc>::size_type) [with _Tp = double; _Alloc = std::allocator<double>; std::vector<_Tp, _Alloc>::reference = double&; std::vector<_Tp, _Alloc>::size_type = long unsigned int]: Assertion '__n < this->size()' failed.
zsh: abort (core dumped)  filmulator

On the other pc I installed Darktable, but then I got the same error message (or something very similar, but again with the “core dumped” bit. RawTherapee instead seems to be working (at least on this one I’m writing now…).
Any idea? Any way to fix this?


P.S. just realised Filmulator is not in the Manjaro repos, but Darktable is, hope this post is still IT then :wink:

Solved! (thanks to a post on Filmulator forum).
I uninstalled the AUR application, then downloaded the AppImage from the Filmulator website, and this one seems to be working flawlessly, so far.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.