Core dump on 3D Render in Kicad 6 - libEGL_mesa is suspect

Since this week’s updates 3D render in KiCad’s pcb editor fails with core dumps. Never did this before latest updates. Version info is:
Application: KiCad PCB Editor
Version: (6.0.9), release build
Libraries:
wxWidgets 3.2.1
libcurl/7.87.0 OpenSSL/3.0.7 zlib/1.2.13 brotli/1.0.9 zstd/1.5.2 libidn2/2.3.4 libpsl/0.21.1 (+libidn2/2.3.4) libssh2/1.10.0 nghttp2/1.51.0
Platform: Linux 5.15.85-1-MANJARO x86_64, 64 bit, Little endian, wxGTK, xfce, x11
Build Info:
Date: Dec 12 2022 07:17:56
wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
Boost: 1.80.0
OCC: 7.6.3
Curl: 7.86.0
ngspice: 38
Compiler: GCC 12.2.0 with C++ ABI 1017
Build settings:
KICAD_USE_OCC=ON
KICAD_USE_EGL=ON
KICAD_SPICE=ON

I looked at the coredump and the bt top shows a SEGFAULT from /usr/lib/libEGL_mesa.so.0

the upgrade log shows that on Dec 21, three days ago, that package libglvnd was upgraded and it contains several libEGL files although not specifically a libEGL_mesa.so.0. I tried a re-install of libglvnd but it didn’t help.

Any help would be appreciated. Top of bt below:

Core was generated by `pcbnew /home/ecomer/Desktop/pcb_projects/kicad/pureaero-relay/pureaero-relay-2l'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007efcc3d8c4e4 in ?? () from /usr/lib/libEGL_mesa.so.0
[Current thread is 1 (Thread 0x7efcadfc56c0 (LWP 1968))]
(gdb) bt
#0  0x00007efcc3d8c4e4 in  () at /usr/lib/libEGL_mesa.so.0
#1  0x00007efcc0541ef3 in  () at /usr/lib/dri/radeonsi_dri.so
#2  0x00007efcc05455de in  () at /usr/lib/dri/radeonsi_dri.so
#3  0x00007efcc0545772 in  () at /usr/lib/dri/radeonsi_dri.so
#4  0x00007efcc3d9d034 in  () at /usr/lib/libEGL_mesa.so.0
#5  0x00007efcc3d9f412 in  () at /usr/lib/libEGL_mesa.so.0
#6  0x00007efcc3d9f7bb in  () at /usr/lib/libEGL_mesa.so.0
#7  0x00007efcc053f41a in  () at /usr/lib/dri/radeonsi_dri.so
#8  0x00007efcc053f5b1 in  () at /usr/lib/dri/radeonsi_dri.so
#9  0x00007efcc0542685 in  () at /usr/lib/dri/radeonsi_dri.so
#10 0x00007efcc0609eca in  () at /usr/lib/dri/radeonsi_dri.so
#11 0x00007efcc060aa56 in  () at /usr/lib/dri/radeonsi_dri.so
#12 0x00007efcc05e4306 in  () at /usr/lib/dri/radeonsi_dri.so
#13 0x00007efcc07d2aca in  () at /usr/lib/dri/radeonsi_dri.so
#14 0x00007efcc07f7878 in  () at /usr/lib/dri/radeonsi_dri.so
#15 0x00007efcc076bec8 in  () at /usr/lib/dri/radeonsi_dri.so
#16 0x00007efcc054e966 in  () at /usr/lib/dri/radeonsi_dri.so
#17 0x00007efcc059e43c in  () at /usr/lib/dri/radeonsi_dri.so
#18 0x00007efd073a88fd in start_thread (arg=<optimized out>) at pthread_create.c:442
#19 0x00007efd0742aa60 in clone3 () at ../sysdeps/unix/sysv/linux/x86_64/clone3.S:81

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

firew4lker reported the problem as being in mesa-22.3. See
https://gitlab.freedesktop.org/mesa/mesa/-/issues/7960

This is out of my league so I’ll need to wait for mesa-22.4 to be ready in Manjaro.