Copying text from Gnome Files does not work anymore

Ever since I upgraded to the new Version (with Gnome 40) I cannot copy text from Gnome Files anymore. It sometimes works (I haven’t found a pattern yet, maybe after restart but idk) but most of the times it does not.
My use case when I notice this the most is when pressing Ctrl+L to show the path in Gnome Files and then trying to copy (Ctrl+C) it to use it in the terminal or whatnot. The same with right click and selecting copy. I cannot paste the text in any other program I tried. However, I can paste it in Gnome Files again.
So it seems to work in some ways within Gnome Files. Like Gnome Files has its own “outgoing” clipboard (for copy and cut) but the pasting works normal (I can copy something anywhere and paste it in the path field of Files).

I also use CopyQ and the “copied” text does not appear in the history list. But the behavior is the same without CopyQ running.

I have 2 laptops both running the latest Manjaro Gnome. Both with an completely new install a couple weeks ago. Both show the same behavior.

I’ve tried to replicate this behavior but can’t seem to get it to fail to copy. Tried the path and renaming copy text.
I don’t use CopyQ but do have Clipboard Indicator (extension) running without any problems.

Does copy/past work without CopyQ?

Looked at the issuelist, it does not seem to be a common issue.

The application has a shortcut to disable storing in the clipboard Ctrl+Shift+X. I’m not accusing you of having fat fingers but this seems like a combination that can be trigged easily, especially on a laptop keyboard.

A logging option is provided, that might give some insight into what is happening if no other users have ready solutions.

I also never experienced this on my previous installations, and I use manjaro gnome and copyq for years. Not sure why it behaves like this now. The only difference to my old installations (besides newer versions) is that I now run wayland.

It’s a fair assumption that my fat fingers would trigger the shift key :wink: but I do not think that is the culprit since it behaves the same with right click and copy/cut.

I have even uninstalled copyq now, still the same.

I like the logging idea, but I don’t know how I would do that.

Since my last restart it is working, also with copyq (which I installed again).
But this was the case before but then at some point it will stop working. I will try to figure out what triggers it.

I tried now multiple restart/suspend cycles. I works (even with copyq) and then just stops working at some point.

I think I might have found what triggers the behavior, although I do not understand why:

  • I restart and everything works
  • I then open KeepassXC and copy anything (I can then paste it but it does not get added to my copyq history, which I set up this way, see below)
  • after that, I can still copy&paste normally, but not anymore from Gnome Files (copied path gets not added to copyq history nor can I paste it anywhere besides within Gnome Files)
  • when I then deactivate my copyq “Command” for KeepassXC, I can then copy again normally even in Files. But of course, whatever I copy from KeepassXC ends up in the copyq history
  • weird thing is that if I then reactivate that command, it still works
  • until I restart, then the circle start from the beginning

These are the command settings:
Type Automatic
Command: copyq ignore
Window: - KeePassXC

I’ve never used CopyQ so not sure what the commands / window options do or know the internals of gnome window management.

The logging option is not that hard to get going, the FAQ has a handy script for it. You are likely to get the most success when logging a issue with the project with your findings and a logfile.

Excelent work btw in finding out when/how this behavior is seen.
(I Wish I had users who where so precise in reporting issues :smiley:

Thank you, I will try to get the logging set up. Unfortunately I will be on the road till the end of the week, so I probably won’t get to it before the weekend