Convert to pipewire

sudo pacman -Ru --nodeps pulseaudio pulseaudio-equalizer pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf pulseaudio-bluetooth pulseaudio-pa pulseaudio-alsa pulseaudio-ctl manjaro-pulse && sudo pacman -S manjaro-pipewire

This no longer works due to package changes. I did a install of i3wm via the manjaro-arm-installer and it installed pulseaudio, no pipewire packages are installed. What is the proper way to remove pulseaudio and replace it with pipewire?

try the first recommended way first;

The older instructions refer to packages that no longer exist: manjaro-pulse, manjaro-pipewire, etc.
Nor do I have them installed:

$ pacman -Ss manjaro | grep installed
core/filesystem 2021.02-2 [installed]
core/manjaro-arm-keyring 20210807-1 [installed]
core/manjaro-hotfixes 2018.08-6 [installed]
core/manjaro-keyring 20210910-2 [installed]
core/manjaro-release 22.01-1 [installed]
core/manjaro-system 20220115-1 [installed]
core/pacman-mirrors 4.23.2-2 [installed]
extra/plymouth-theme-manjaro 1-1 [installed]
community/adapta-maia-theme [installed]
community/artwork-manjaro-arm-i3 20190121-1 [installed]
community/conky-i3-pinebook 20200308-1 (i3-manjaro) [installed]
community/dmenu-manjaro 5.0-2 (i3-manjaro) [installed]
community/i3-arm-scripts 20200312-1 [installed]
community/i3exit 20201126-1 (i3-manjaro) [installed]
community/i3status-manjaro 2.13-3 (i3-manjaro) [installed]
community/manjaro-arm-i3-settings 20200920-1 [installed]
community/manjaro-arm-wallpapers 20220109-1 [installed]
community/papirus-maia-icon-theme 20200702-2 [installed]
community/rpi4-post-install 20211125-3 [installed]
community/st-manjaro 1:0.8.2.r31.g51e19ea-1 [installed]
community/sterminal 0.11-1 [installed]
community/vertex-maia-themes 20180519-4 [installed]
community/xcursor-maia 20160417-1 [installed]

Looking at what pulse packages are installed:

$ pacman -Ss pulse | grep installed
extra/libpulse 15.0-1 [installed]
extra/pavucontrol 1:5.0-1 [installed]
extra/pulseaudio 15.0-1 [installed]
extra/pulseaudio-alsa 1:1.2.6-2 [installed]
extra/pulseaudio-bluetooth 15.0-1 [installed]

If you simply install pipewire-pulse (and replace the packages it mentions) it should use a pipewire service instead of pulseaudio on reboot.

1 Like

Thank you, that worked.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.