Controller Mapping skewed everywhere except Heroic's Launcher

Hello all,
I’m having a funny issue with my Xbox one controller. Until recently it has worked flawlessly over bluetooth using xpadneo. However, recently the mapping for games on steam have been -without a more accurate term- borked. I have also tested it on the game controller page in system settings and through an online tester( with the same results. Examples of wrong mapping include: LT = RS left right, RT = LT, LB = Y and Y = X. These ‘borked’ mappings seem to go away when playing a game through Heroic, I’ve tried Rocket League and Sonic Mania and they work normally with a controller. My steam controller profile settings are normal and the problem persists before Steam is even open. On xpadneo’s wiki it states that

If you see wrong button mappings / missing buttons in SDL applications, or rumble does not work, you may need to turn off this behavior by setting an environment variable in your profile: SDL_JOYSTICK_HIDAPI=0

Me being a linux dummy I have no clue how to implement this solution or if this scenario even pertains to me. I’m on Manjaro KDE version 21.3.2 using kernel 5.18.7-1. If you have any suggestions please let me know. Thanks.