Controller Bluetooth button mapping scrambled. Need help

Hello fellow Manjaro gamers. I’m having some issues as follow:

I recently bought a Gulikit King Kong 2 Pro controller. Model NS09. This controller has four different connection mode however I’m now only trying to focus on X-input Wireless through Bluetooth because I’m having problem with this one.

For starter I’m currently on 5.15.91-1-MANJARO Kernel and gcc (GCC) 12.2.1 20230111. All packages updated and the system is running fresh. Gnnome 43.2

On Gamepad-Tester it shows all my buttons working correctly. However in Steam, the button mapping is wrong. For example:

Right Trigger => Right Bumper
Right Bumper => Left Stick Press
Left Stick Press => Left Bumper

Some other modes include Switch Pro Wire/Wireless. Android Wireless. D-input Wired/Wireless and X-input wired. All these modes work fine with no button mapping or rumble issues.

So obviously I have searched the forums in hope of finding solution before posting. Here are some of the stuff I found and have tried but did not offer a full solution:

  • Installing xpadneo driver package on AUR. So what it does to my controller is turning X-input layout into D-input. It did “fixed” the button layout however what it does is cause the rumble motor to always vibrate and turning rumble OFF in Steam DID NOT work. So obviously I had to remove the package.
  • Installing linux-515-headers for the Kernel. Did not work.
  • Using Timeshift to rewind back to before the system patch. Did not work.

As far as I’m aware this might be a kernel driver bug. However I did not find any mention of Xbox driver stuff. After searching through the update log of Pamac I found that

[2023-02-03T17:19:49+0700] [ALPM] upgraded linux515 (5.15.89-1 -> 5.15.91-1)

Feb 3rd was when the Kernel patch happens however the controller was still working fine up until about a day ago so I’m not sure which package caused the issue. I currently do not have any other kernel version installed. As shown here.

I would appreciate if I can get some help here. If you have any ideas please do.

It seems pretty clear that no one has been able to find a solution other than to wait for another system kernel patch? So I switched to EndeavourOS. Solved this problem because they use newer kernel from Arch upstream. Good bye.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.