Continuous coredumps from appimagelauncherd


I’m continually getting coredumps in my syslog from appimagelauncher. The coredumps occur every minute and I’m not sure what I need to do to resolve. Can anyone give some tips?

    Process 775137 (appimagelaunche) of user 1000 dumped core.

Stack trace of thread 775137:
#0  0x00007f9f3887f2e0 _ZNK4QDireqERKS_ ( + 0x1cd2e0)
#1  0x000055c5c6d7845e n/a (appimagelauncherd + 0x1f45e)
#2  0x000055c5c6d66c4a n/a (appimagelauncherd + 0xdc4a)
#3  0x00007f9f3899edd6 n/a ( + 0x2ecdd6)
#4  0x00007f9f389a2e4b _ZN6QTimer7timeoutENS_14QPrivateSignalE ( + 0x2f0e4b)
#5  0x00007f9f389944bf _ZN7QObject5eventEP6QEvent ( + 0x2e24bf)
#6  0x00007f9f38967a50 _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent ( + 0x2b5a50)
#7  0x00007f9f389bfa65 _ZN14QTimerInfoList14activateTimersEv ( + 0x30da65)
#8  0x00007f9f389c034a n/a ( + 0x30e34a)
#9  0x00007f9f39b32914 g_main_context_dispatch ( + 0x52914)
#10 0x00007f9f39b867d1 n/a ( + 0xa67d1)
#11 0x00007f9f39b31121 g_main_context_iteration ( + 0x51121)
#12 0x00007f9f389c06e1 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE ( + 0x30e6e1)
#13 0x00007f9f389663fc _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE ( + 0x2b43fc)
#14 0x00007f9f3896e894 _ZN16QCoreApplication4execEv ( + 0x2bc894)
#15 0x000055c5c6d65255 n/a (appimagelauncherd + 0xc255)
#16 0x00007f9f3831a152 __libc_start_main ( + 0x28152)
#17 0x000055c5c6d656ce n/a (appimagelauncherd + 0xc6ce)
CODE_FILE	../systemd-stable/src/coredump/coredump.c
CODE_FUNC	submit_coredump
COREDUMP_CGROUP	/user.slice/user-1000.slice/user@1000.service/appimagelauncherd.service
COREDUMP_CMDLINE	/usr/bin/appimagelauncherd
COREDUMP_COMM	appimagelaunche


I saw the same. Not sure what’s causing it, I’ll look into it when I have the chance.

I think I found the issue. Updated packages pushed to all branches.

Wow! That was quick. I presume the updated packages are not generally available yet as I have updated my system today but still getting the same error.

I dug a bit deeper into this.

From what I see, the core dumps are being generated by the pcloud appimage. The coredumps are being generated every 40 seconds. I stopped the pcloud application and checked to see that there were no pcloud processes running using “ps -ef”. Strangely, core dumps are still being generated by pcloud - hours after I stopped the application!

I had a look at the core dump files using the great information from arch-wiki-coredumps. From what I can see, a SIG 11(Segmentation Fault) is being generated for these coredumps.

What’s the output of:

systemctl --user status appimagelauncherd.service

Output of “systemctl --user status appimagelauncherd.service”:

Failed to connect to bus: No such file or directory

Output of “systemctl status appimagelauncherd.service”:

Unit appimagelauncherd.service could not be found

That’s odd. How about:

systemctl --user --failed

Normally AppImageLauncher enables the service automatically on first run. Try enabling it and check the status again:

systemctl --user enable --now appimagelauncherd.service
systemctl --user status appimagelauncherd.service

Output from the commands:

Please post the output as Preformatted text, not screenshots.

[john-msi ~]# systemctl --user --failed
Failed to connect to bus: No such file or directory
[john-msi ~]# systemctl --user enable --now appimagelauncherd.service
Failed to connect to bus: No such file or directory
[john-msi ~]# systemctl --user status appimagelauncherd.service
Failed to connect to bus: No such file or directory
[john-msi ~]

Don’t use sudo with systemctl --user.

Ok, but I get the same result whether I use sudo or not.

Don’t use a root prompt, either.