Continued Black Screen Issue

I still can’t boot into an existing system. Both ESC and alt+ctrl+Fx are inoperable after system boot screen. I can get to grub via the ISO-USB option and have done the “e” edit removing quiet and splash and adding the nvidia_drm fix. Also tried adding the 3to switch. In no case will the system boot to a terminal and in fact hangs at various places on what would be the install menu. Any thoughts, this ia a
high dollar system that’s making me crazy! All help much appreciated!

Have you asked before to resolve it?
You used “still”. Is there a history here?

ESC right after power on will let you see the Grub menu.
There you can press “e” and edit the command line to temporarily change it.

alt+ctrl+Fx will let you switch between TTY’s - but only after the system has finished booting.

No idea about “nvidia_drm fix”
But: editing the Grub options on the live ISO will, of course, have no effect on the Grub configuration of your “real” installation.

To alter that, you have to boot the live system, enter chroot (manjaro-chroot) to get into your actual system, then you can edit /etc/default/grub to remove these options, and after that run update-grub
then exit the chroot and reboot your actual system.

It’s possible that I misunderstood the situation - in that case: try describing it with context and in more detail.

I used “still” because there were a large number of previous posts on the issue and I’ve tried all the fixes that were posted and none worked. As I said, pressing ESC after boot does nothing.

You may try pressing shift, but it may dont work at all systems.

When you write

it sounds more like, you edit grub from your USB-ISO, but then start again from your hdd,
which then could be, that your grub at your hdd dont work, or you have a bad boot order.
You need to change then the right boot order inside your bios.
You can first try to hit F12 during boot up, it should give you a menu, where you can choose where to boot from.
Try to boot normal from your hdd(s), i dont know if you got 2 hdd on your system and if nothing happens, try again with F12 starting from the hdds but then spam pressing esc, and once more with pressing shift during start up, to see if you get the grub menu.
If nothing works, then you can try to boot up from the usb-iso, use manjaro-chroot -a and reinstall grub to your hdd like shown here. I dont know, what system you have, so you have install it by your own for EFI or boot system.

If you cannot manage to get to see the Grub menu - how do you know that the system even boots?
ESC at any point will at least let you see some messages - even if you where not fast enough to catch the Grub menu.
spam the key …

Editing anything on the live system is useless - you use the live system to eventually change root (manjaro-chroot) into your system to interact with it and fix it.

I cannot reconcile this with your description that you can neither boot nor get to see the Grub menu.
plus: I don’t know them
“I’ve tried everything” does carry very little useful information.

If you can make it boot by add nvidia_drm.modeset=1 to command line and you still have issues - you may have neglected to add to default grub config and rebuild the config.

So, what was the thing about starting with the simplest solution? I swapped keyboards and all the problems went away! ESC now works, edited the boot menu, opened a live terminal, edited /etc file,
did a cfg update and everything works just fine. How often does one have a bad keyboard, but it certainly explains my problems. Thanks for all the advice and help.

1 Like

Better this than PEBKAC - the fix would not have been so easy :grin: