Connectivity / security certificate problem after Manjaro update

I’ve only been on Linux since March 2020 and I’ve been on Manjaro KDE most of that time. I’ve never had any problems with updates before but there is a first time for everything.

I ran the big update yesterday and subsequently restored from timeshift as I thought the graphics card driver changes were an error as things looked so different in the mhwd gui. I’ve since read up on the forum and I see this is the way it’s meant to be now.

So I ran the update again and this time got the graphics card thing sorted out, but then I found I couldn’t connect to any sites via firefox or chromium, and thunderbird couldn’t connect to my email servers either. All these connectivity problems were related to a change of security certificate, or the browser or system not recognising it. I really don’t understand what exactly was wrong but it appears that my system lost something it needs related to security certificates.

Can anybody advise what happened please.

Double-check your locale settings (region and time)

I can’t do that right now as I ran timeshift again to fix the system. I’m back on pre-update Manjaro now.

Next time I run it I’ll give that a shot.

I’m asking these questions as I have no idea of the answers. Do you think my locale could have been changed by the updates somehow? And if so does that mess you up for https certificates?

https/certs break if the clock is wrong. So its possible.

Ok thanks. Next time I try the updates I’ll check that straight away.

I see you are on the Manjaro Team. I love your operating system. Thank you for the work you do !!! :+1: :+1: :+1: