Connection issues using wireguard

Good Morning/Afternoon/evening

I’m not sure to post this question in the proper category…

I have created a Nextcloud local server and I use a wireguard VPN to access it remotely.

The thing is when I create a config file to access my local network, I can import it on my phone (in the wireguard app) or in the wireguard client of windows. In these cases, the connection works fine, and I’m able to connect to the internet or to my Nextcloud server. But If I import the same config file in a linux system (I tried manjaro and linuxmint) I get a notification when connecting saying: “connection activated” and I’m not able to connect to the internet (let say google_com) or to my local nextcloud server…

Maybe I’m doing something wrong but when I want to import my config file on manjaro, I go to the connection settings, then I click on the + button (add a new connection), then import a VPN connection (from a config file). I also tried to manually create a wireguard VPN but doesn’t work…

So I suppose it’s a configuration problem on linux system that I don’t get and that the issue doesn’t come from the VPN in itself…
But honestly, after a lot of time trying to find a solution… I need your help.

Thanks in advance to anyone that can help me!

Have a nice day,
Best regards,

What do you mean by “import”? Import in some GUI application or in NetworkManager (NM)?

For testing it is better to use wg-quick , for example as root (sudo also works)

wg-quick up /path/to/wgconfig.conf

If there are no errors, then check the wg command, again it needs to be run as root or with sudo


Is the connection established? You might need to wait a little bit. If you see a peer, try to ping IP address in your wirguard network, in your local network and in the Internet. If that works try DNS. A usual problem is that DNS is not working, which might look as a connection problem.

The commands are part of the wireguard-tools package.

When you have the .conf file copy that to the kernel. Then start wireguard with sudo wg-quick up /etc/wireguard/yourfile.conf When finished close with sudo wg-quick down /etc/wireguard/yourfile.conf You also need to install wireguard-tools (pamac) If it works you see a small padlock on the network icon.

Good evening,

So I finally managed to connect properly thanks to your advices…
I don’t understand why it only works through command line…

But anyway, thanks a lot for your help!