Connecting a usb digital microscope to laptop running Manjaro XFCE

Hi, having problems with my Svbony usb digital microscope connecting to my HP laptop.I am running Manjaro 21.0 and XFCE 4.16.
When I plug the usb in and type lsusb in the command line, it shows up as can be seen in the attached screenshot. Svbony do not have Linux software, only Windows and Mac!
I have tried various packages including Cheese, guvcview and digiKam but sadly, nothing works. Please help![


Please let us know the exact model …

Well, from your screenshot, what you tried is to run from terminal:
tar.zxfj /home/brianm/Downloads/guvcview-src-2.0.7-2.tar.bz2
And in spite that you got:
bash tar.zxfj: comand not found
you still tried …

That command is NOT found because the tar.zxfj is not a valid command !!!
tar -xvjf is a valid command to extract

  • -x: Extract, retrieve the files from of the tar file.
  • -v: Verbose, list the files as they are being extracted.
  • -j: Bzip2, use bzip2 to decompress the tar file.
  • -f: File, name of the tar file we want tar to work with.

… so correct would be
tar -xvjf /home/brianm/Downloads/guvcview-src-2.0.7-2.tar.bz2 and probably you should provide the target where to extract the archive …

But guvcview is available in our repositories, no need to download the source. Run from terminal:

pamac install guvcview

And then open it.

So, how would we go about it then? If they have a proprietary software (and it looks like so) there is nothing we can do. It seems they provide some software for linux but only for their astronomy devices …

Thanks very much for your prompt reply, yes, I did eventually get guvcview installed from the repository, but that didn’t work either.
Why do you think it is that the microscope camera is not being activated if it is recognised as a usb device? I have asked SvBony about the software for Linux, but it’s pretty much a dead end at this stage. It is a SV604 model microscope

And how is listed in the camera software you tried?

Can be recognized as USB device, but if there is no device ID to identify it as USB Camera, then there will be no way to capture any image from it. If requires a special firmware/driver and software, and there is no equivalent for it in linux, is simply an unknown device connected to USB.
On your lsusb i see no trace of SVBony of any kind. If you refer to the 05c8:0379 cheng uei precision industry - that seems to be the device id of the HD camera of your HP laptop.

The 05e3:f12g genesys logic should be connected to USB3 from what i read around, and you might need to build the libuvc-git from AUR …

Good morning bogdancovaiu, thanks, I think it is the Genesys Logic device, as it is not in the list when not connected.

You might need to build the libuvc-git from AUR …

Do I get this from AUR repository through Add software and try to install it from there? Sorry, I’m a 71 year young ignorant guy when it comes to the workings of Linux!
I’ll give that a shot now.

Scrolling through all the libuvc packages, there are plenty with ROS prefix. It seems like there may be something there, so after I test the libuvc-git from AUR package if that doesn’t work, I’ll work my way through them. Hopefully there is a solution there somewhere.
Thanks for your help so far!

You will have to enable AUR from Pamac Preferences, yes, or you do it from terminal:
pamac build libuvc-git

Sometimes we have to face the fact that some devices simply do not have support for linux …

WHOOOOO!! Success! I may be a complete ignoramus in matters Linux, but I never let a problem get me! He He!
I searched, found this site , How to access Arducam UVC Cameras using OpenCV, Python, and GStreamer Introduction on Linux

Followed the steps for Python, as I have used cv2 and Python a bit in the past.
I played with the camera numbers and hit the jackpot.
My code:
import cv2
cap = cv2.VideoCapture(2qqq1)

cap.set(cv2.CAP_PROP_BRIGHTNESS, 64)
cap.set(cv2.CAP_PROP_CONTRAST, 0)

# Capture frame-by-frame
ret, frame =
# Display the resulting frame
cv2.imshow(‘frame’, frame)
if cv2.waitKey(1) & 0xFF == ord(‘q’):


But I have to get it to quit by pressing ‘q’ otherwise it runs into an error state, with this: ‘/usr/bin/python3.9 /usr/share/pycharm/plugins/python-ce/helpers/pydev/ --multiproc --qt-support=auto --client --port 33835 --file “/home/brianm/PycharmProjects/MICROSCOPE CAM/”
Connected to pydev debugger (build 212.5284.44)
Corrupt JPEG data: 1431 extraneous bytes before marker 0xd9’

You would most likely be able to write some script for Linux, I certainly wouldn’t have a clue where to start, but I will try installing gstreamer if there is a package.
It’s not 100% yet, but at least about 100 steps in the right direction.
Thanks for you help so far. I need to get the video running.

Stay safe


Sorry, just noticed the error in the second line , it should be:
cap = cv2.VideoCapture(2) not cap = cv2.VideoCapture(2qqq1) my finger trouble!

Glad you sort it out. Will mark your reply as solution then, but feel free to add any other information to the topic if find suitable. Also, you can always edit the comment and correct things, and if there is some code, better to use the formatting for it, mention if is a script or a command run from terminal.

I would like to get it running smoothly before we mark it as solved, otherwise people who try it will get very frustrated.
i’ll spend a bit of time on it this evening and keep you updated.
Thanks again, Brian.

An often overlooked app for capturing/converting/displaying video streams is good old vlc.
‘Media’ >> ‘Open capture device’ lets you pick a stream from attached (and functioning) hardware, might be worth a try, especially if you have it installed already.

1 Like

Thanks, I will give it a try as I do have VLC already installed. That would be a real bonus if it worked. I’ll let you know how I get on.
I am also just trying to get the correct Python code working so it works seamlessly, then we can mark it as Solved.

Morning 6x12 I gave VLC a shot, but no luck. I’ll keep working on the Python code.